Bug 505343 - Hundreds of places.sqlite-*.corrupt files in the profile directory
Hundreds of places.sqlite-*.corrupt files in the profile directory
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 11:02 EDT by anenokoji
Modified: 2009-06-25 05:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 05:09:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 493291 None None None Never
Mozilla Foundation 493374 None None None Never

  None (edit)
Description anenokoji 2009-06-11 11:02:52 EDT
Description of problem:  I thought I was mistaken, but I did have 110gb free disk space before upgrading to f11.  


Version-Release number of selected component (if applicable):  3.5b4


How reproducible: Don't know.  Work machine, don't feel like trying over.


Steps to Reproduce:
1.  Use preupgrade to upgrade to f11
2.  use firefox
3.  
  
Actual results:  in the profile directory(under ~/.mozilla/firefox), there are numerous places.sqllite-$NUMBER.corrupt

file count:
[momo@kendo 5wrbz4cp.default]# ls -l | wc -l
2918

portion of ls -l
...
-rw-r--r--. 1 momo momo 48545792 2009-06-10 11:09 places.sqlite-996.corrupt
-rw-r--r--. 1 momo momo 48545792 2009-06-10 11:10 places.sqlite-997.corrupt
-rw-r--r--. 1 momo momo 48545792 2009-06-10 11:10 places.sqlite-998.corrupt
-rw-r--r--. 1 momo momo 48545792 2009-06-10 08:40 places.sqlite-99.corrupt
...

[momo@kendo firefox]# du -h --max-depth=1
32K     ./Crash Reports
111G    ./5wrbz4cp.default
111G    .


Expected results:  


Additional info:  None of my firefox data was saved.  I was running binaries of 3.5b4 in f10 and never had any problems.  Now, I have numerous problems with this firefox.  The address bar doesn't work, it'll stop loading web pages.  I've also uninstalled and re-installed firefox via yum.  Let me know if there is any other data that I can provide.
Comment 1 anenokoji 2009-06-11 11:11:42 EDT
So, I will update the bug.  Even using the binary from mozilla.org within 2 minutes of being opened it created almost 50 .corrupt files.
Comment 2 anenokoji 2009-06-11 16:09:07 EDT
OK, so it looks like my profile was corrupted.  It's running fine now after making a new one.  So, somehow during the f11 preupgrade something went awry.
Comment 3 Matěj Cepl 2009-06-15 07:29:56 EDT
I don't know, I haven't seen profile corruption much lately (sqlite apparently *IS* more stable). I can either close this as "who knows what happened?" bug (aka NOTABUG), or push this upstream to bugzilla.mozilla.org is they have any thoughts. What do you prefer?
Comment 4 Matěj Cepl 2009-06-25 02:44:37 EDT
Well, unfortunately, I can full reproduce this bug with already upgraded and installed firefox.

bradford:t5k6klu2.default$ ls places.sqlite-*.corrupt|wc -l
904
bradford:t5k6klu2.default$ 

Apparently that "upgrade" part is a red herring. It could happen even with already working F11.

Will investigate further.
Comment 5 Matěj Cepl 2009-06-25 02:55:03 EDT
Looks like https://bugzilla.mozilla.org/show_bug.cgi?id=493374 has the fix
Comment 6 Martin Stransky 2009-06-25 05:06:50 EDT
It's fixed in the upcoming firefox 3.5 RC.
Comment 7 Martin Stransky 2009-06-25 05:09:38 EDT
closing as upstream (actually it's already fixed by mozilla).

Note You need to log in before you can comment on or make changes to this bug.