Bug 505349 - user-switch-applet doesn't update display after name change
user-switch-applet doesn't update display after name change
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 11:15 EDT by Jason Woofenden
Modified: 2015-01-14 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 15:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Woofenden 2009-06-11 11:15:34 EDT
Description of problem:

The user-switch-applet doesn't update it's display in the panel after editing the name/headline field under "Pdit Personal Information"

Version-Release number of selected component (if applicable):

gnome-panel 2.26.1

How reproducible:

Only tried once, presumably always.

Steps to Reproduce:
1. I right-click the user-switch-applet, select "Edit Personal Information"
2. Click your name at the top, change it, press enter to stop typing, then click "close".
3. Enter your password for authorization, and it says "information updated"
  
Actual results:

Name in user-switch-applet does not change

Expected results:

I expect to see my new name shown in the panel

Additional info:

If I'm changing my name in some obscure system settings dialog (like the users and groups thing) then I wouldn't be too surprised if the user-switch applet didn't update, but whet I change it by right-clicking on it, it had better.
Comment 1 Jason Woofenden 2009-06-11 11:21:19 EDT
FWIW I've discovered that if I remove the user-switch-applet from the panel and then add it again, it gets the new name. So this clearly is not a matter of needing to log out and log back in to get an updated session/env.
Comment 2 Matthias Clasen 2009-06-11 20:59:04 EDT
The applet is part of gdm now.
Comment 3 Sergey Rudchenko 2009-09-07 15:42:10 EDT
Thanks for the bug report.

This problem seems to be resolved in the current development version (F12). The user name on the "Account information..." dialog became a static text.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.