Bug 505350 - Package groups broke my network :(
Package groups broke my network :(
Status: CLOSED DUPLICATE of bug 520489
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 11:17 EDT by Máirín Duffy
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 10:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2009-06-11 11:17:25 EDT
Description of problem:

So I installed @kde-desktop in order to solve a rather strange problem. (attempted to switch ok/cancel buttons in KDE so that i wouldn't keep closing KDE apps on accident. didn't work, btw.) 

Since I was sick of having tons of KDE apps I don't use in my app menus, I decided to clean house and yum remove @kde-desktop. Big mistake. It removed NetworkManager-gnome. Why @kde-desktop includes NetworkManager-gnome rather than something like NetworkManager-kde, I simply don't know (and perhaps this is then a bug with comps for @kde-dekstop. IF so feel free to move.)

Anyhow, it really sucks (on a laptop with no CD or DVD drive) to be in the situation where your network no longer works and you have no easy way to repair it because you have no network. 

I was thinking that if you remove a package group that contains packages that other packages outside the group require for functionality, that the package group removal would fail so I falsely assumed I was safe by going ahead and performing the group removal. Ideally, I would like it if there were some way a policy could be set using flags or if yum interactively would ask me (probably both since we need to support unattended operations I think) something like this:

If you remove @kde-desktop, the following packages required by other packages outside of @kde-desktop will be removed:

NetworkManager-gnome
foo-package
bar-package

Would you like to continue with the removal but keep these packages? Y/n

Just an idea anyway. And I did get the laptop fixed but it was painful and scary.
Comment 1 seth vidal 2009-09-17 10:38:25 EDT

*** This bug has been marked as a duplicate of bug 520489 ***

Note You need to log in before you can comment on or make changes to this bug.