Bug 505403 - gdm crashes on login
gdm crashes on login
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-06-11 15:00 EDT by Panu Matilainen
Modified: 2015-01-14 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:54:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors containing the crash and bunch of other funny messages (7.49 KB, text/plain)
2009-06-11 15:00 EDT, Panu Matilainen
no flags Details
More detailed traceback of the crash (8.15 KB, text/plain)
2009-06-13 04:59 EDT, Panu Matilainen
no flags Details

  None (edit)
Description Panu Matilainen 2009-06-11 15:00:25 EDT
Created attachment 347457 [details]
.xsession-errors containing the crash and bunch of other funny messages

Description of problem:

Gdm is crashing at login semi-regularly, see the attached beauty of a backtrace from ~/.xsession-errors

Version-Release number of selected component (if applicable):
gdm-2.26.1-10.fc11.x86_64

How reproducible:
Almost every time - right after installation it worked exactly once, after that each time. I had similar experiences with F11-preview but didn't get around to test it further + report it then (other issues making it too painful to play more with the preview)

It appears to be related to using hesiod: if I add a duplicate my hesiod user account locally, the crashes disappear.

Steps to Reproduce:
1. Setup hesiod (+ kerberos for auth in my case)
2. Try to login to a to a valid account
  
Actual results:
Crash and burn, until local account is added+used instead.

Expected results:
The same setup worked fine in F10...
Comment 1 Ray Strode [halfline] 2009-06-11 15:30:23 EDT
> "arguments to %s() were incorrect, assertion \"%s\" failed in file %s line 
> %d.\nThis is normally a bug in some application using the D-Bus library.\n") at > dbus-internals.c:283
> gdm[2998]: #8  0x00000032fb210278 in dbus_connection_send_with_reply_and_block (
We're probably trying to pass non-utf8 text over the wire

Can you debuginfo-install gdm and get a more complete backtrace?

Also the output of 

getent passwd

would be useful.
Comment 2 Panu Matilainen 2009-06-13 04:59:31 EDT
Created attachment 347725 [details]
More detailed traceback of the crash

Hmm, the above was with gdm debuginfo installed, so its some other component here... a few dozen debuginfos later :) Here's a more detailed crash.

Something funny with getent, it only shows local users unless you specificy a username:
[pmatilai@turre ~]$ getent passwd pmatilai
pmatilai:x:500:500:Panu Matilainen:/home/pmatilai:/bin/bash
[pmatilai@turre ~]$ getent passwd|grep pmatilai

FWIW F10 seems to behave the same and gdm seems to be only thing that minds, I can login to the box over ssh and from a vt without problems.
Comment 3 Jonas Nyman 2009-09-27 06:53:02 EDT
gdm-2.26.1-13.fc11  Gave me similar problems. It crashes when I select username. The window starts to shrink but before it reaches the state where I can type in password it crashes and restarts... 

I could login clicking "other user", then writing user name and password. 
But I would sometimes be thrown out of gnome after a few minutes, when it crashed again. 

Downgrading to gdm-2.26.1-10.fc11.x86_64 helped.
Comment 4 Bug Zapper 2010-04-27 10:47:02 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-06-28 08:54:04 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.