Bug 505410 - RFE: Allow overriding releasever with a specific version in addition to a package
RFE: Allow overriding releasever with a specific version in addition to a pac...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:03 EDT by Bruno Wolff III
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 14:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-06-11 16:03:29 EDT
Description of problem:
It makes doing a yum update a little bit easier if I can say something like:
yum --releasever=11 update
and not have to manually tweak repo files or alternatively fetching a copy of fedora-release and trying to install that first.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2009-06-11 17:50:00 EDT
 Upstream this is easy to do, in code, now. And also upstream it's possible to have cachedir be releasever specific.
 The biggest problem is getting something from the command line into yum before releasever is used (as a plugin you can't do it atm. because releasever is used before plugin arguments are parsed). In theory we can add it to core, but it seems like a pretty small edge case to add a core option for.
Comment 2 seth vidal 2009-09-17 14:53:00 EDT
I think having cachedir be able to use $releasever/$basearch takes care of this problem.
for example:

cachedir=/var/cache/yum/$basearch/$releasever

I've made this the default in the yum.conf in rawhide/f12.

Note You need to log in before you can comment on or make changes to this bug.