This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505412 - Install freezes
Install freezes
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:11 EDT by Dave
Modified: 2014-06-09 10:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave 2009-06-11 16:11:58 EDT
Description of problem:

Unable to install Fedora 11. Locks and/or takes a *long* time to get through particular steps.

Version-Release number of selected component (if applicable):

Fedora 11 public distribution

How reproducible:

Always, but in varied ways.

Steps to Reproduce:
1. Install
2.
3.
  
Actual results:

Install freezes - sometimes on "Creating file system on /dev/sda", sometimes on "installing kernel-pae-2.6...".

Expected results:

Getting through install.

Additional info:

Been attempting to install Fedora 11 for two days. The furthest I got was the package install of "kernel-pae-2.6..." (screen didn't change for hours). Installing on Asus R1F laptop with Intel Core2 T7200 2ghz CPU. (I've run The last 4 or 5 Fedora releases on this laptop without install issues, currently happily running Fedora 10 on another partition.)

Also _long_ pauses at other points during install. The last attempt I documented them:
Finding storage devices: 2:15 (over two minutes)
Root password [next]: 2:30
Create custom layout: 1:35
Edit partition: /dev/sda [ok]: 1:30
After custom partition [next]: 0:45
the following will be formatted [format]: 0:55
[Write changes to disk]: 1:20
Creating filesystem on...: 30:00 (then I rebooted)
Comment 1 Chris Lumens 2009-06-11 16:17:22 EDT
How much memory do you have?  When it freezes, does it completely lock up, or can you still switch to tty2 and try things out there?
Comment 2 Dave 2009-06-11 16:46:12 EDT
Good afternoon, Chris.

I have 2GB RAM.

It seems as though I can switch to tty2, although switching back to tty6 doesn't redraw the gui. (The mouse cursor moves as it should at all times in the gui.) I'm able to "ps" and "top", so it seems as though I should be able to gather evidence (if I only knew what to do).
Comment 3 Andy Lindeberg 2009-06-12 10:56:02 EDT
Can you run memtest86+ and let us know if you get any errors? As an FYI, it can take a while to complete (say, a couple days).
Comment 4 Dave 2009-06-12 15:28:14 EDT
I ran memtest86+ from the Fedora11 install DVD. I'm not sure how long it's supposed to run, but I did let it go through two passes - no errors (it took about two hours). I ran another Fedora 11 install, and it was stuck at installing kernel-PAE-2.6... overnight. Not knowing how it all works, my suspicions lean toward PAE or the installation of the kernel. Could it be that the install thinks I have PAE when I don't? (I can't figure out whether or not I have PAE, although flags in /proc/cpuinfo on Fedora 10 does show it.) Could it be that the kernel install is attempting to build the grub configuration, and is having trouble with my partition setup? Anything else in common with the long pause points and the installation of the kernel?

(I've also tried installs from two brands of DVD media on two different burners on two different machines, plus a CD install attempt.)
Comment 5 Dave 2009-06-17 16:19:01 EDT
I've attempted installs a few more times (with a few variations in option choices), and the kernel install is as far as I ever make it. I've run memtest86+ a few times, the last of which I let it run 10 passes.

The only other thing I can think of that I have that's unique, is the number of partitions on my drive. I have 11 partitions on /dev/sda, and am attempting to install onto sda6 (which is part of an extended partition, just like my Fedora 10 install, which is on sda8). I've tried both without a boot partition, and using my current boot partition (/dev/sda5) for the new boot partition. I've tried both ext3 and ext4 for the "/" partition. (It won't let me use ext4 for /boot, though.) I've tried "customize now" and "customize later" for packages.

Any ideas, or things to try next?
Comment 6 Andre Robatino 2009-07-01 15:09:33 EDT
My father is trying to do a clean install of F11 and is currently seeing this.  The "creating filesystem on /dev/sda1" seems to run forever.  I told him to try leaving the machine to run overnight in the unlikely event it finishes.  On an earlier attempt we used top on VT2 to see what was happening.  An Xorg process was using 90+ percent of the CPU, and anaconda was using around 3 percent.  Is it reasonable for X to use up so much?
Comment 7 Andre Robatino 2009-07-02 15:39:54 EDT
We tried getting past the "creating filesystem on /dev/sda1" by using xdriver=vesa and then acpi=off, without any change.  A text-based install did succeed but results in a horribly stripped-down system.  It would be nice if there was a walkthrough somewhere on how to get the result of such an install up to the result of a default GUI install.  So far we've only been able to figure out how to use useradd and passwd to create an ordinary user account, but not how to get the network up in order to add packages.
Comment 8 Andre Robatino 2009-07-07 14:38:54 EDT
After installing, we experienced extremely slow X performance, which turned out to be bug #500063 affecting the savage video driver.  (All versions from RH 9 to F10 previously installed and worked normally on this machine.)  I suspect that's also the cause of our installation problem.  Unfortunately I never considered the possibility of trying the install using the basic video option.  Oh well.  Dave, your video driver wouldn't happen to be savage, by any chance?
Comment 9 Dave 2009-07-07 15:47:35 EDT
I don't think my problem is with the video driver - I believe I have an integrated Intel GMA 950 graphics adapter. I can NOT get through an install and am waiting on a resolution before I can continue. (I was able to install Fedora 11 in a VirtualBox virtual machine on my running Fedora 10, but that doesn't do me much good.)

My suspicions lean toward either an incompatibility of the PAE kernel (and no known way to tell it to install non-PAE), or something to do with the partitions I have on my machine. I have never been able to get past the kernel installation, and there are LONG pauses at times during the install when it seems to be reading the partitions on the disk.
Comment 10 Dave 2009-07-08 00:59:28 EDT
Just for fun, I tried a basic video install, and a text install. They both stopped for 2.5 minutes at the first reading of the partition table. I let the basic video install go through all the steps, and it stopped at the kernel package install, as usual.

I'm leaning more and more toward something in my partition table that Fedora/Anaconda doesn't like. Maybe an fdisk output would help? I'm attempting to install F11 on sda6, and mounting /boot as sda5 (but not formatting sda5). I've also attempted installing without a separate boot partition (everything on sda6).

[root@asus ~]# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
129 heads, 4 sectors/track, 1892971 cylinders
Units = cylinders of 516 * 512 = 264192 bytes
Disk identifier: 0xd0e6c1b4

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               4       27787     7168000   1c  Hidden W95 FAT32 (LBA)
/dev/sda2   *       27788      146857    30720060    7  HPFS/NTFS
/dev/sda3          146858     1892971   450497412    f  W95 Ext'd (LBA)
/dev/sda5          146858      150826     1024000   83  Linux
/dev/sda6          150827      320635    43810720   83  Linux
/dev/sda7          320636      336511     4096006   82  Linux swap / Solaris
/dev/sda8          336512      501177    42483826   83  Linux
/dev/sda9          501178      659936    40959820   83  Linux
/dev/sda10         659937      660730      204850   83  Linux
/dev/sda11         660731      668668     2048002   83  Linux
[root@asus ~]#
Comment 11 Pat Barron 2009-07-14 16:45:05 EDT
I've seen this exact same behavior on an IBM 8654-51Y (xSeries 330).  Graphical install gets to "Creating filesystem on /dev/sda1", and hangs there forever, with the progress indicator bouncing back and forth, no disk activity, and (according to "ps") the only process picking up any CPU time being the X server.  This is reliably repeatable.  I have forced it to proceed beyond this point by making it not format /dev/sda1 (the partition being already there and formatted from previous attempts); however, in this case, it then proceeds to format the (ext4) root filesystem, which hangs in exactly the same way.  There's a great deal of disk activity, which eventually stops (when mke2fs finishes, I would suppose), but the install never proceeeds past this point.

Possibly of interest is that "ps" (from the shell on virtual console 2) shows the "mke2fs" command that created the filesystem on /dev/sda1 to be in "exiting" state; I presume that anaconda is supposed to wait for it and collect it's exit status, but that's apparently not happening.  Also possibly of interest is that the output of the "mke2fs" command (in virtual console 4, I think) is only shown partially.  In fact, it only gets as far as (someting like - I don't have the exact output in front of me):

mke2fs 1.41.4 (27-Jan-2009)
Filesy

Yes, the output stops in the middle of the line, and the cursor is at the end of the line.

A GUI upgrade of this system from F10 to F11 fails similarly (done either from DVD, or via "preupgrade"), the system hangs in a similar way at the end during the "Finalizing upgrade" process - hangs there forever with the progress bar bouncing back and forth.  I've let this run as long as 24 hours, and it never finishes.  I don't know if this is related to this bug or not, but I include the info in case it's useful.

This system is able to successfully install Fedora 10 via the graphical installer.  And installing Fedora 11 in text mode works, as well.  But installing Fedora 11 via the graphical installer hangs like this every time.
Comment 12 Dave 2009-08-15 19:39:07 EDT
Two more failed experimental attempts:

1) I have two sticks of memory (1GB each). I removed one and ran the install. It stuck at the same place (kernel install). I removed the other stick of memory and put the first one back in - same results.

2) I clean-installed Fedora 10 without problems. I then tried an upgrade of the clean Fedora 10 to Fedora 11. The upgrade tried to install the non-PAE kernel, but still failed at the kernel install step.

My suspicions about Fedora 11 not liking my partition table is stronger, now that I've tried these two things. I've been telling Fedora11 to use /dev/sda5 as boot, and /dev/sda6 as / (most of the time). I don't know what else to try...
Comment 13 Andre Robatino 2009-08-15 19:53:45 EDT
The fact that memtest86+ ran for 10 passes without detecting a problem means that you could probably have discounted bad memory.  Fedora Unity should be coming out with a F11 respin soon, you could try that when it happens in the hope it's an installer bug that got fixed.
Comment 14 Bug Zapper 2010-04-27 10:47:26 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Iyan 2010-05-09 10:01:35 EDT
I still have this problem in Fedora 13 Beta... :( Always crash while formatting and if I use the Text Instalation it works with no problem, but the problem is I have a Fedora without Xorg.
Comment 16 Bug Zapper 2010-06-28 08:54:31 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.