Bug 505413 - Gimp Crash XServer on click over an image
Gimp Crash XServer on click over an image
Status: CLOSED DUPLICATE of bug 505823
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:12 EDT by Hiran Arias
Modified: 2009-06-16 04:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 04:30:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg Conf File (2.47 KB, text/plain)
2009-06-11 16:12 EDT, Hiran Arias
no flags Details

  None (edit)
Description Hiran Arias 2009-06-11 16:12:08 EDT
Created attachment 347467 [details]
Xorg Conf File

Description of problem:
Gimp Crash XServer on click in the image window

Version-Release number of selected component (if applicable):
gimp-2.6.6-3.fc11.x86_64

How reproducible:
Select any tool from the ToolBox and click over an image (new or existent)

Actual results:
XServer get restarted and the Greeting Login Screen appears closing all running graphics applications.

Additional info:

Gimp packages installed:
gimp-data-extras-2.0.2-2.fc11.noarch
xsane-gimp-0.996-7.fc11.x86_64
gimp-libs-2.6.6-3.fc11.x86_64
gimp-2.6.6-3.fc11.x86_64

Video: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]



The following errors were capture on crash:
gimp: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

(script-fu:25716): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Comment 1 Nils Philippsen 2009-06-12 07:52:25 EDT
The X server crashing sounds like a driver or server problem to me (even though I have to different Radeon models that don't show this behaviour). I'll change the component to xorg-x11-drv-ati, you should probably tell the maintainer whether you use the radeon or radeonhd driver.
Comment 2 Hiran Arias 2009-06-12 09:06:11 EDT
The driver used is radeonhd, I'm changing the component to that driver. There are other issues with the driver including that all graphics are very slow in general.
Comment 3 Richard Schwarting 2009-06-16 03:09:11 EDT
This sounds the same as this bug 505823 which occurred to an intel user (like me), so I think it's not just driver specific in this case.  I'll upload my Xorg.0.log there.
Comment 4 Nils Philippsen 2009-06-16 04:30:57 EDT
In that case I'll close/dupe this bug.

*** This bug has been marked as a duplicate of bug 505823 ***

Note You need to log in before you can comment on or make changes to this bug.