Bug 505414 - (acp1) Brightness buttons suspend laptop
Brightness buttons suspend laptop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-power-manager (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:13 EDT by Ajit C Pilai
Modified: 2009-06-24 15:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.8.0-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:31:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ajit C Pilai 2009-06-11 16:13:03 EDT
Description of problem:
After installing xfce4-power-manager, the brightness control on my laptop (FN + F6/F7) correctly changed the brightness of the computer screen, however, they also hibernated the computer. I have disabled the "put computer to hibernate when the hibernate button is pressed" and have looked through various settings for some kind of conflict but can't find it.

Version-Release number of selected component (if applicable):
Fedora 11 XFCE4

How reproducible:
Everytime

Steps to Reproduce:
1. Press FN + F6 or FN + F7
2.
3.
  
Actual results:
Brightness decreases/increases correctly and computer then hibernates

Expected results:
Brightness decreases/increases correctly

Additional info:
Comment 1 Christoph Wickert 2009-06-11 17:19:39 EDT
What Laptop are you using and what version of xfce4-power-manager. I guess you are talking about xfce4-power-manager-0.8.0-0.3.RC1.fc11.x86_64, right?

Please try the latest packages from 
http://koji.fedoraproject.org/koji/buildinfo?buildID=105486 if they still show the same problem. If so, start the power-manager from a terminal with the "--no-daemon" parameter, press the buttons and post the output here. Use an attachment if it is too much.
Comment 2 Christoph Wickert 2009-06-12 20:18:06 EDT
The update is now also available at 
https://admin.fedoraproject.org/updates/xfce4-power-manager-0.8.0-1.fc11

Please let me know if it fixes your problems. TIA.
Comment 3 Lesley Mitchell 2009-06-13 07:14:48 EDT
(In reply to comment #2)
> The update is now also available at 
> https://admin.fedoraproject.org/updates/xfce4-power-manager-0.8.0-1.fc11
> 
> Please let me know if it fixes your problems. TIA.  

This update fixes an identical issue on the Acer Aspire One.
Comment 4 Christoph Wickert 2009-06-13 09:31:03 EDT
That was my hope because upstream's ChangeLog mentiones:
"Don't accept any event for non mapped buttons".

Thanks for your report Lesley. How about the you Ajit?
Comment 5 Ajit C Pilai 2009-06-13 12:34:07 EDT
I'm having trouble installing it. I'm running xfce4-power-manager-0.8.0-0.2.beta1.fc11 and it claims it is the newest version.
Comment 6 Christoph Wickert 2009-06-13 12:47:25 EDT
It's not yet pushed to the mirror servers, you have to manually download it from 
http://kojipkgs.fedoraproject.org/packages/xfce4-power-manager/0.8.0/1.fc11/x86_64/xfce4-power-manager-0.8.0-1.fc11.x86_64.rpm and install it with rpm -Uvh .
Comment 7 Ajit C Pilai 2009-06-13 13:03:11 EDT
Fixed my problem. Thanks!
Comment 8 Fedora Update System 2009-06-15 22:27:21 EDT
xfce4-power-manager-0.8.0-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-power-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6394
Comment 9 Fedora Update System 2009-06-24 15:31:03 EDT
xfce4-power-manager-0.8.0-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.