This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505420 - pkgorder misses some kernel packages
pkgorder misses some kernel packages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:36 EDT by Dennis Gregorovic
Modified: 2013-01-10 00:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 15:11:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2009-06-11 16:36:58 EDT
Description of problem:
In pkgorder:

    # hack, hack, hack... make sure iscsi ends up on disc1 (#208832)                                                                                  
    addPackages(ds, ["kernel-*","mkinitrd","mdadm"])
...
    #Everthing else but kernels                                                                                                                       
    for po in ds.pkgSack.returnPackages():
        if po.name.find("kernel") == -1:
            member = ds.tsInfo.addInstall(po)

Because the two fragments of code search on different criteria, it's possible for packages to not get picked up by pkgorder.  In particular, the kerneloops package is missed.

Version-Release number of selected component (if applicable):
pungi-2.0.16-1.fc11

How reproducible:
always

Steps to Reproduce:
1./usr/bin/pkgorder on a tree with the kerneloops package
2.
3.
  
Actual results:
kerneloops not included in output

Expected results:
kerneloops included in output

Additional info:
Comment 1 Jesse Keating 2009-06-12 14:46:51 EDT
Hrm, good catch.  Should just change that second search to kernel- instead of kernel.
Comment 2 Jesse Keating 2009-12-22 15:11:11 EST
Fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.