Bug 505456 - iwl3945 killswitch works only once
iwl3945 killswitch works only once
Status: CLOSED DUPLICATE of bug 498622
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 19:43 EDT by Chris
Modified: 2009-07-07 13:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 13:52:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2009-06-11 19:43:31 EDT
Description of problem:
The RF killswitch works only once. Activating the killswitch is possible, deactivating it again does not work.


Version-Release number of selected component (if applicable):
iwl3945-firmware-15.32.2.9-1.fc11
kernel-PAE-2.6.29.4-167.fc11.i686

How reproducible:
always

Steps to Reproduce:
1. Boot with RF killswitch disabled
2. Enable killswitch
3. Disable it again
  
Actual results:
##Killswitch enable event here
iwl3945: No space for Tx
iwl3945: Error sending REPLY_CARD_STATE_CMD: iwl3945_enqueue_hcmd failed: -28
iwl3945: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.
##Killswitch disable event here

Expected results:
Enabling and disabling again should be possible.

Additional info:
none
Comment 1 John W. Linville 2009-06-19 22:53:02 EDT
Can you do an 'ifconfig wlan0 up' after disabling the killswitch?
Comment 2 Chris 2009-06-20 03:44:17 EDT
# ifconfig wlan0 up
SIOCSIFFLAGS: No such device
Comment 3 John W. Linville 2009-06-30 10:13:01 EDT
That seems odd...maybe the firmware error leads to deregistering the device?

What about if you do a 'modprobe iwlagn' first?
Comment 4 reinette chatre 2009-06-30 12:03:07 EDT
(In reply to comment #0)
> Description of problem:
> The RF killswitch works only once. Activating the killswitch is possible,
> deactivating it again does not work.

Could you please elaborate on "does not work"? 

> 
> 
> Version-Release number of selected component (if applicable):
> iwl3945-firmware-15.32.2.9-1.fc11
> kernel-PAE-2.6.29.4-167.fc11.i686
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. Boot with RF killswitch disabled
> 2. Enable killswitch
> 3. Disable it again

What do you do as step 4 to test if there is a problem?

> 
> Actual results:
> ##Killswitch enable event here
> iwl3945: No space for Tx
> iwl3945: Error sending REPLY_CARD_STATE_CMD: iwl3945_enqueue_hcmd failed: -28
> iwl3945: Radio Frequency Kill Switch is On:
> Kill switch must be turned off for wireless networking to work.
> ##Killswitch disable event here

The rfkill log messages are not very friendly here. We have the rfkill enabling messages as a warning, but the disabling is a debug message. So, if you just go by the log messages (and you do not have debugging enabled) then it will seem as though rfkill is still enabled when it is not. You can get a better idea of what is going on by enabling debugging (make sure driver is compiled with CONFIG_IWL3945_DEBUG) and load module with "modprobe iwl3945 debug=0x20000" or "modprobe iwl3945 debug=0x63fff).
Comment 5 Stanislaw Gruszka 2009-07-03 02:51:34 EDT
This bug looks _very_ similar as 498622. Christian could you try kernel provided here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1446949
Comment 6 John W. Linville 2009-07-07 13:52:57 EDT

*** This bug has been marked as a duplicate of bug 498622 ***

Note You need to log in before you can comment on or make changes to this bug.