Bug 505457 - installing proxy 5.3 through webUI results in not having rhn-proxy-activate command
installing proxy 5.3 through webUI results in not having rhn-proxy-activate c...
Status: CLOSED NOTABUG
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 20:03 EDT by Justin Sherrill
Modified: 2009-06-12 09:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 08:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-06-11 20:03:31 EDT
it appears that the rhn-proxy-activate command has been moved to the proxy-installer package which resides in the rhn-tools channel.  This means that if you install proxy through the webUi that package is not installed and thus rhn-proxy activate is not available. 


1.  register a system
2.  through webUI activate it as a proxy (installing proxy)
3.  try to run rhn-proxy-activate
Comment 1 Clifford Perry 2009-06-11 22:49:58 EDT
Well - the WebUI installation will activate the Proxy. If using the WebUI you then deactivate and re-activate, it is activated. 

The *need* to use rhn-proxy-activate is maybe if you re-registered the Proxy server and needed to re-activate, without installation of Proxy. Either way, if your using WebUI, the WebUI will do all this. If your using command line installer, then you get rhn-proxy-activate. If you wish to flip from managing Proxy via WebUI to command-line, the installation of the proxy-installer package is a very easy command. 

Also, WebUI installer for Sat 5.3 is deprecated with preference for command line proxy installer. I am in favor of closing this out as NOTABUG.

Mirek - agree? 


Cliff.
Comment 2 Miroslav Suchý 2009-06-12 08:56:01 EDT
rhn-proxy-activate was in version prior to 5.3 intended for internal use only (like gss), it was not something customer was expected to use. So we even do not need to mention that it documentation.
Either way, if you want it you can install spacewalk-proxy-installer and you have it.

Note You need to log in before you can comment on or make changes to this bug.