Bug 505465 - Bluetooth Audio only in mono
Bluetooth Audio only in mono
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 21:11 EDT by Steven Drinnan
Modified: 2009-06-13 07:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 23:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Drinnan 2009-06-11 21:11:10 EDT
F11 I have to say is fantastic - Everything working out of the box. Just this minor feature request would make it awesome.


Description of problem:
When I connect my A2DP bluetooth I can only get mono sound.



Not really a bug but a feature request.

Version-Release number of selected component (if applicable):
2.27.5

How reproducible:

Every time



Steps to Reproduce:
1. Pair bluetooth headset
2. Device is connected in mono
3.
  
Actual results:
Connected as HCP


Expected results:

Should give you the option to connect as H2DP or HCP not just assume HCP.


Additional info:

As I said not really a bug. 

I have a H2DP headset, that sounds great in stereo mode but mediocre in mono.

Problem: Gnome bluetooth only connects headsets as HCP.

My idea is that when you first pair the device you create 2 device entries. One that is HCP (Standard Headset with microphone) the other as H2DP (only a stereo connection no microphone.

Ideally the user should be able to select the preferred connection but just having the option in the device list would be fantastic.

Steven
Comment 1 Bastien Nocera 2009-06-12 02:38:46 EDT
It's A2DP and HSP.

You should be able to switch the profile using PulseAudio, in pavucontrol.
Comment 2 Steven Drinnan 2009-06-12 21:11:20 EDT
Sorry my mistake about HSP I hate abbreviations they always get me confused.

Will check out pavucontrol. But I need to recover my headset from my daughter. But I do see now the configuration tab that was not there before. So it looks like it will do the trick.

Steven
Comment 3 Steven Drinnan 2009-06-12 23:08:41 EDT
Confirmed that pavucontrol can change the profile.

May be that package should no be included by default.

So you can change to not a bug. Sorry for the unnecessary report. And thanks for your advice. :)
Comment 4 Bastien Nocera 2009-06-13 07:39:24 EDT
The feature will be merged into the volume control in the future.

Note You need to log in before you can comment on or make changes to this bug.