Bug 505502 - Profile selection not retained
Profile selection not retained
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 02:14 EDT by Robert Hancock
Modified: 2009-06-29 19:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 19:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Hancock 2009-06-12 02:14:41 EDT
Description of problem:
When selecting a different output configuration profile using pavucontrol, the setting is lost when pulseaudio is restarted.

I have a VIA Envy24HT-based sound card which has the SPDIF output on hw:0,1 which I want to use. If I set the profile to Output Digital Stereo (IEC958) + Input Analog Stereo (which is what I want), it seems to work, but when pulseaudio gets restarted it goes back to Output Analog Stereo + Input Analog Stereo.

(Also, what about multichannel analog output, that doesn't seem to show up when 7.1 channel output should be available on hw:0,0, but that's another story..)

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-11.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Set profile to IEC958 output using pavucontrol
2. pulseaudio -k, or log out and back in
3. start pavucontrol again
  
Actual results:
Setting has returned to default

Expected results:
Setting should persist

Additional info:
Comment 1 Marek Zukal 2009-06-12 09:42:58 EDT
I have slightly different problem but potentially related. I set the profile to Output Analog Surround 5.1 + Input Analog Stereo. This works for every stereo stream connected to pulse audio at the time of the setting change. i.e. the stereo channels are cloned to respective 6 channels as expected. When the pulse is restarted or even a stream reconnects(amarok - forced change of track) the profile selection stays unchanged but the sound is stereo only. Changing the profile to something else and back helps until the stream gets reconnected again.
Comment 2 Marek Zukal 2009-06-12 09:51:17 EDT
Sorry for mislead. Seems that it is not "stereo only" as I posted before. I just noticed that the the only speaker that wents out after the stream gets reconnected is the sub-woofer(lfe).
Comment 3 Lennart Poettering 2009-06-29 08:10:25 EDT
Marek: please don't hijack unrelated bug reports. If in doubt always create a seperate bug report and let the devs merge them as duplicates if needed. PA does not synthesize LFE anymore by default. You can reenable that by editing /etc/pulse/daemon.conf.

Robert, have you touched dfault.pa in any way? Are you sure module-card-restore is loaded properly on your setup? Please paste the output of "pacmd ls"!
Comment 4 Robert Hancock 2009-06-29 19:59:42 EDT
Sorry, it looks like this was due to changes I made to default.pa previously in order to get the SPDIF output to work, and then when I upgraded to F11 the file didn't get updated. After restoring the original default.pa it looks like things are OK now.

In particular it looks like I was missing the load-module module-card-restore and load-module module-augment-properties lines..

Note You need to log in before you can comment on or make changes to this bug.