Bug 505531 - Unable to adjust LCD backlight on macbook 4,1 (Intel GM965)
Unable to adjust LCD backlight on macbook 4,1 (Intel GM965)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 05:25 EDT by Chris Nolan
Modified: 2009-09-09 10:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 10:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of lshal (140.58 KB, text/plain)
2009-06-12 05:25 EDT, Chris Nolan
no flags Details
Output of lspci -v (7.39 KB, text/plain)
2009-06-12 05:26 EDT, Chris Nolan
no flags Details
Output of lspci -v on MacBook 5,1 (5.57 KB, application/octet-stream)
2009-06-13 16:04 EDT, Derek Hildreth
no flags Details
Output of lshal | egrep ... (532 bytes, text/plain)
2009-06-13 17:39 EDT, Derek Hildreth
no flags Details
output of lshal (654 bytes, application/octet-stream)
2009-06-15 20:34 EDT, Jereme Kramer
no flags Details

  None (edit)
Description Chris Nolan 2009-06-12 05:25:32 EDT
Created attachment 347525 [details]
Output of lshal

== Description of problem: ==

Unable to adjust backlight on MacBook 4,1 

== Version-Release number of selected component (if applicable): ==

hal-0.5.12-26.20090226git.fc11.x86_64
DeviceKit-power-008-0.1.20090401git.fc11.x86_64
DeviceKit-003-1.x86_64
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64

== How reproducible: ==

Always

== Steps to Reproduce: ==

Under gnome, running gnome-power-manager...

1. Press brightness up or down keys, or disconnect from power
  
== Actual results: ==

No adjustment in screen brightness

== Expected results: ==

Screen brightness should adjust

== Additional info: ==

Key presses are correctly identified by hal but nothing actually happens:

$ lshal -m

Start monitoring devicelist:
-------------------------------------------------
10:14:25.621: usb_device_5ac_22a_noserial_if0_logicaldev_input condition ButtonPressed = brightness-down
10:14:26.997: usb_device_5ac_22a_noserial_if0_logicaldev_input condition ButtonPressed = brightness-u

Possibly a duplicate of #503220 but I'll leave that for the developers to decide. 

If you need any more info please let me know.
Comment 1 Chris Nolan 2009-06-12 05:26:18 EDT
Created attachment 347526 [details]
Output of lspci -v
Comment 2 Derek Hildreth 2009-06-13 16:03:09 EDT
This same problem exists for the MacBook Aluminum 5,1 with Fedora 11.

==========================================
lahal -m output: 
==========================================

Start monitoring devicelist:
-------------------------------------------------
14:00:30.540: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = brightness-down
14:00:30.964: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = brightness-up
14:00:31.516: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = kbd-illum-down
14:00:31.876: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = kbd-illum-up
Comment 3 Derek Hildreth 2009-06-13 16:04:23 EDT
Created attachment 347762 [details]
Output of lspci -v on MacBook 5,1
Comment 4 Derek Hildreth 2009-06-13 17:39:56 EDT
Created attachment 347773 [details]
Output of lshal | egrep ...

Ran the following command and received the output attached.

lshal | egrep "(system.hardware(product|vendor|version)|system.firmware.version|power_management.quirk)"
Comment 5 Min 2009-06-14 03:48:09 EDT
Same happened in Fedora 64 bit on Macbook 5,1 (aluminum)

output of
lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"

  power_management.quirk.dpms_on = true  (bool)
  power_management.quirk.dpms_suspend = true  (bool)
  power_management.quirk.vbe_post = true  (bool)
  power_management.quirk.vbemode_restore = true  (bool)
  power_management.quirk.vbestate_restore = true  (bool)
  power_management.quirk.vga_mode_3 = true  (bool)
  system.firmware.version = '    MB51.88Z.0073.B06.0810291326'  (string)
  system.hardware.product = 'MacBook5,1'  (string)
  system.hardware.vendor = 'Apple Inc.'  (string)
  system.hardware.version = '1.0'  (string)
Comment 6 Chris Nolan 2009-06-14 07:00:29 EDT
Found a workaround for this:

Disable Kernel Mode Setting by adding the following kernel boot parameter:-

nomodeset

You may also want to add the following kernel boot parameter as well if you want to see the animated Plymouth startup screen:-

vga=0x315

More info:

http://forums.fedoraforum.org/showpost.php?p=1226504&postcount=21
http://forums.fedoraforum.org/showpost.php?p=1224232&postcount=2
https://bugzilla.redhat.com/show_bug.cgi?id=496975
https://bugzilla.redhat.com/show_bug.cgi?id=502516

This fix works for me.
Comment 7 Jereme Kramer 2009-06-15 20:34:56 EDT
Created attachment 348034 [details]
output of lshal

This bug is also present in the MacbookPro 5,3.  Disabling Kernel Mode Setting doesn't fix the problem.  I attached the output of lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"
Comment 8 Derek Hildreth 2009-06-18 11:05:20 EDT
I tried to add the nomodeset option to grub with no resolution.  Backlight still can't be controlled.

I re-ran the lshal -m output with the nomodeset option and I got something a little different than before.  Thought maybe it would be good to include here.

Start monitoring devicelist:
-------------------------------------------------
09:00:37.731: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = brightness-up
09:00:38.431: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive = false (new)
Unknown type 0=''
09:00:38.435: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name =  (new)
Unknown type 0=''
09:00:38.437: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked =  (new)
Unknown type 0=''
09:00:38.440: computer property info.named_locks =  (new)
09:00:38.441: computer interface_lock_acquired org.freedesktop.Hal.Device.SystemPowerManagement by :1.117 (1 lockers)
09:00:38.441: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.exclusive removed
09:00:38.441: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.locked removed
09:00:38.441: computer property info.named_locks.org.freedesktop.Hal.Device.SystemPowerManagement.dbus_name removed
09:00:38.441: computer property info.named_locks removed
09:00:38.441: computer interface_lock_released org.freedesktop.Hal.Device.SystemPowerManagement by :1.117 (0 lockers)
09:00:38.547: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = brightness-down
09:00:44.611: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = brightness-up
09:00:45.963: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = brightness-down
09:00:46.843: usb_device_5ac_236_noserial_if0_logicaldev_input condition ButtonPressed = brightness-up
Comment 9 Michael 2009-06-21 21:31:26 EDT
I am using a Macbook 5,1. The screen brightness adjustment keys (F1,F2) do not do anything. I am currently using the 2.6.29.5 kernel.

I have briefly used the 2.6.31 kernel in Rawhide and the keys are recognised in so far as they bring up the screen brightness icon on the screen but while the icon indicator changes the actual screen brightness is not affected.

This leads me to believe this problem in F11 will be solved by a kernel patch and some other sticky bits to glue the functionality together.
Comment 10 Konstantin Svist 2009-07-09 14:31:48 EDT
I have this problem on a Dell Vostro 1500.
This laptop has an nvidia chipset, so Fedora defaults to using nouveau (if it's any difference). nomodeset doesn't do anything, since kernel can't modeset with nouveau yet.

$ lshal -m output

Start monitoring devicelist:
-------------------------------------------------
11:07:14.861: platform_i8042_i8042_KBD_port_logicaldev_input condition ButtonPressed = brightness-down
11:07:14.869: computer_logicaldev_input condition ButtonPressed = brightness-down                     
11:07:15.757: platform_i8042_i8042_KBD_port_logicaldev_input condition ButtonPressed = brightness-up  
11:07:15.768: computer_logicaldev_input condition ButtonPressed = brightness-up                       

Brightness can be controlled from command line utility (solid-powermanagement) and from battery applet in KDE.
Comment 11 humufr 2009-07-13 03:55:04 EDT
Same problem with a thinkpad T400 and intel gm45 graphic card. The button are not working but after to be log with gnome desktop it's working, with kde the button are not working but you can change the brightness with the plasmoid and the other desktop (windowmaker) or the console it's just not working. 

By the way it's a fedora specific bug, this problem doesn't exist with (k)ubuntu or mandriva.
Comment 12 Scott Glaser 2009-09-09 09:58:06 EDT
Have you tried with the latest hal package in Fedora 11 or tried Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Hugh Merz 2009-09-09 10:05:58 EDT
I can confirm that this is now working on a Macbook 5,1 and 2.6.30.5-43.fc11.x86_64
Comment 14 Scott Glaser 2009-09-09 10:38:00 EDT
I am going to mark this bug as closed based on comment 13. Should you again encounter this bug, please file a new bug against the applicable component.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.