Bug 50554 - gdm-2.2.3.1-8 won't build cleanly
gdm-2.2.3.1-8 won't build cleanly
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gdm (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 00:36 EDT by R P Herrold
Modified: 2007-03-26 23:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 10:14:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-08-01 00:36:00 EDT
gdm-2.2.3.1-8.src.rpm

RH 7.1 patched to current, with all autoconf and related updates, as needed
to build gdm-2.2.2-4   from rawhide a couple of weeks ago ...

gcc -O2 -march=i386 -mcpu=i686 -g -Wall -Wpointer-arith
-Wmissing-prototypes -Wmissing-declarations -o gdmlogin gdmlogin.o
gdmlanguages.o gdmwm.o misc.o -rdynamic -rdynamic -rdynamic  -L/usr/lib
-L/usr/X11R6/lib -lgnome -lgnomesupport -laudiofile -lm -lm -laudiofile -lm
-ldb1 -ldl -lgnomeui -lart_lgpl -lgdk_imlib -lSM
-lICE -ldl -lm -ldl -lm -ldl -lgnome -lgnomesupport /usr/lib/libesd.so
-laudiofile -lm -lm -laudiofile -lm -ldb1 -ldl -ldl -ldl
/usr/lib/libgdk_pixbuf.so -ldl /usr/lib/libgtk.so /usr/lib/libgdk.so
/usr/lib/libgmodule.so /usr/lib/libglib.so
-ldl -lXi -lXext -lX11 -lm -ltiff /usr/lib/libjpeg.so -lpng -lz
/usr/lib/libwrap.a -lnsl -lpam -lXinerama
gdmlogin.o: In function `main':
/usr/src/redhat/BUILD/gdm-2.2.3.1/gui/gdmlogin.c:3439: undefined reference
to `gnome_dialog_grab_focus'
collect2: ld returned 1 exit status
make[2]: *** [gdmlogin] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/gdm-2.2.3.1/gui'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/gdm-2.2.3.1'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.53176 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.53176 (%build)
[root@couch src]#
[root@couch src]#
Comment 1 Havoc Pennington 2001-08-01 10:13:53 EDT
Some dimwit added interfaces to the stable libgnomeui. I am flaming them now.


Should probably add a build requires there, but it should not be necessary,
there is no good reason that interface was added.
Comment 2 Havoc Pennington 2001-08-01 11:59:29 EDT
build requires will be in gdm 2.2.3.1-9

Note You need to log in before you can comment on or make changes to this bug.