Bug 505540 - statd: Hostname mismatch causing problems between RHEL and NetApp
statd: Hostname mismatch causing problems between RHEL and NetApp
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.3
All Linux
low Severity high
: rc
: ---
Assigned To: Steve Dickson
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 06:40 EDT by Sachin Prabhu
Modified: 2010-10-23 06:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 13:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Prabhu 2009-06-12 06:40:50 EDT
A notify request sent by a client is being ignored by the server resulting in unclaimed file locks on the server. The client in this case is a RHEL and the NFS server a Netapp server. The problem appears to be caused by a mismatch in the hostnames used by lockd and by statd.

The hostname on the server is set to a short name(ex: test). This short name is used by lockd when setting the hostname from which the locks were requested. 

The /etc/hosts is setup in such a way that a FQDN(ex: test.example.com) is returned by gethostbyaddr(). This is used by statd on the client when notifying servers that the machine has rebooted.

This is causing a problem on their Netapp servers which expects the same hostname used to set the locks and in by statd. 

This is a request to have the statd and the lockd to use the same source for setting hostnames.

Note You need to log in before you can comment on or make changes to this bug.