Bug 505589 - rubygem-RedCloth-debuginfo created from stripped binaries
rubygem-RedCloth-debuginfo created from stripped binaries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-RedCloth (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-06-12 10:30 EDT by Ville Skyttä
Modified: 2015-06-21 20:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.1.9-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 00:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2009-06-12 10:30:43 EDT
Just removing the "strip" line from the specfile should fix this.  But it uncovers another problem; the build root gets someway included in the fixed debuginfo package so further work is required to get it past check-buildroot.

See bug 496968 for more info.
Comment 1 Mamoru TASAKA 2009-07-14 13:13:15 EDT
I wrote some comments on fedora-devel-list about what is
happening to this spec file.
Comment 3 Fedora Update System 2009-07-14 14:49:33 EDT
rubygem-RedCloth-4.1.9-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rubygem-RedCloth-4.1.9-5.fc10
Comment 4 Mamoru TASAKA 2009-07-14 14:59:09 EDT
(In reply to comment #3)
> rubygem-RedCloth-4.1.9-5.fc10 has been submitted as an update for Fedora 10.
> http://admin.fedoraproject.org/updates/rubygem-RedCloth-4.1.9-5.fc10  

This is not correct. find-debuginfo.sh won't search for source codes
under /tmp and actually build.log says:
--------------------------------------------------------
extracting debug info from /builddir/build/BUILDROOT/rubygem-RedCloth-4.1.9-5.fc10.i386/usr/lib/ruby/site_ruby/1.8/i386-linux/redcloth_scan.so
0 blocks
-------------------------------------------------------
So debuginfo rpm is not correctly created.

As I posted on fedora-devel-list, gem file _must_ be installed
under %_builddir because find-debuginfo.sh expects that source
codes are expanded there.
Comment 5 Fedora Update System 2009-07-14 15:03:35 EDT
rubygem-RedCloth-4.1.9-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rubygem-RedCloth-4.1.9-5.fc11
Comment 6 Mamoru TASAKA 2009-07-14 15:07:48 EDT
(In reply to comment #5)
> rubygem-RedCloth-4.1.9-5.fc11 has been submitted as an update for Fedora 11.
> http://admin.fedoraproject.org/updates/rubygem-RedCloth-4.1.9-5.fc11  

... and this is not correct, either.
Comment 7 Fedora Update System 2009-07-19 06:10:38 EDT
rubygem-RedCloth-4.1.9-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rubygem-RedCloth'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7712
Comment 8 Fedora Update System 2009-07-19 06:18:45 EDT
rubygem-RedCloth-4.1.9-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rubygem-RedCloth'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7747
Comment 9 Fedora Update System 2009-07-30 10:02:05 EDT
rubygem-RedCloth-4.1.9-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rubygem-RedCloth-4.1.9-6.fc10
Comment 10 Fedora Update System 2009-07-30 10:34:24 EDT
rubygem-RedCloth-4.1.9-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rubygem-RedCloth-4.1.9-7.fc11
Comment 11 Fedora Update System 2009-07-31 14:06:01 EDT
rubygem-RedCloth-4.1.9-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rubygem-RedCloth'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8168
Comment 12 Fedora Update System 2009-07-31 14:07:15 EDT
rubygem-RedCloth-4.1.9-7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rubygem-RedCloth'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8174
Comment 13 Fedora Update System 2009-09-04 00:04:04 EDT
rubygem-RedCloth-4.1.9-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-09-04 00:06:01 EDT
rubygem-RedCloth-4.1.9-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.