Bug 505596 - rpmlib does not link, yum stops working
rpmlib does not link, yum stops working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 10:40 EDT by Stepan Kasal
Modified: 2009-06-12 11:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 11:00:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2009-06-12 10:40:45 EDT
Description of problem:
after "yum update rpm"; yum no longer works:

$ yum list foo
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /usr/lib/librpm.so.0: undefined symbol: cap_compare

Please install a package which provides this module, or
verify that the module is installed correctly.

... etc.

Indeed:

# ldd -r /usr/lib/librpm.so.0
undefined symbol: cap_compare   (/usr/lib/librpm.so.0)


Steps to Reproduce:
1. have libcap-2.10
2. yum update rpm
3. yum update anything  # won't work
Comment 1 Stepan Kasal 2009-06-12 10:51:29 EDT
This problem caused by a bug in libcap, failed as bug 505598
Comment 2 Stepan Kasal 2009-06-12 11:00:50 EDT
fixed in rpm-4.7.0-6

Note You need to log in before you can comment on or make changes to this bug.