Bug 505612 - s390x invalid error about tomcat restarting during install
s390x invalid error about tomcat restarting during install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Pavel Studeník
na
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2009-06-12 11:21 EDT by wes hayutin
Modified: 2013-10-01 17:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-12 11:21:54 EDT
Description of problem:

6/12 build on rhel5 remote db, selinux enforcing



* Restarting services.
Tomcat failed to start properly or the installer ran out of tries.  Please check /var/log/tomcat5/catalina.out for errors.
Installation complete.
Visit https://rhndev5.z900.redhat.com to create the RHN Satellite administrator account.
[root@rhndev5 mount]# less /var/log/tomcat5/catalina.out
[root@rhndev5 mount]# tail 10 /var/log/tomcat5/catalina.out
tail: cannot open `10' for reading: No such file or directory
==> /var/log/tomcat5/catalina.out <==
Jun 12, 2009 11:09:02 AM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jun 12, 2009 11:09:03 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Jun 12, 2009 11:09:03 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/27  config=null
Jun 12, 2009 11:09:03 AM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Jun 12, 2009 11:09:03 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 30732 ms
[root@rhndev5 mount]#
Comment 1 Devan Goodwin 2009-06-17 15:55:43 EDT
* Restarting services.
Installation complete.
Visit https://lister.z900.redhat.com to create the RHN Satellite administrator account.
You have new mail in /var/spool/mail/root
[root@lister satiso]# 


Is this speedy hardware? Also was the application actually working shortly after this or was it actually unreachable? Has this happened multiple times or just once?
Comment 2 wes hayutin 2009-06-19 08:01:24 EDT
[root@rhndev5 ~]# cat /proc/cpuinfo 
vendor_id       : IBM/S390
# processors    : 2
bogomips per cpu: 3270.24
processor 0: version = FF,  identification = 070AFE,  machine = 2094
processor 1: version = FF,  identification = 070AFE,  machine = 2094
[root@rhndev5 ~]# 

[root@rhndev5 ~]# free
             total       used       free     shared    buffers     cached
Mem:       4118580    1415984    2702596          0     196668     559380
-/+ buffers/cache:     659936    3458644
Swap:      1048552          0    1048552
[root@rhndev5 ~]# 


tomcat eventually started ok.  Our time out may not have been long enough for this hardware
Comment 3 Devan Goodwin 2009-06-19 09:25:05 EDT
Alright let's ON_QA this one for a retest?
Comment 10 Clifford Perry 2013-10-01 17:56:23 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.