Bug 505624 - automount blocks NFS mount points in fstab
automount blocks NFS mount points in fstab
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 11:57 EDT by Jerry Amundson
Modified: 2009-07-02 09:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 09:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2009-06-12 11:57:09 EDT
Description of problem:
automount blocks NFS mount points in fstab

Version-Release number of selected component (if applicable):
autofs-5.0.4-28.x86_64

How reproducible:
Always, since sometime during F11's rawhide anyway.

Steps to Reproduce:
1.add fstab entries for nfs, pointing to nis server
2.(not really sure if the combined nfs/nis server is key)
3.reboot, with autofs service enabled
  
Actual results:
NFS filesystems are mounted, but unavailable:

[root@jerry-opti755 ~]# mount | grep nfs
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
stpftp:/home/exports/mirrors/centos on /opt/pub/mirrors/centos type nfs (ro,addr=10.111.1.244)
guinan:/u/public on /public type nfs (rw,addr=10.111.1.61)
guinan:/users on /users type nfs (rw,addr=10.111.1.61)
[root@jerry-opti755 ~]# ls /users /public
/public:

/users:
[root@jerry-opti755 ~]# lsof +d /users /public
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/jerry/.gvfs
      Output information may be incomplete.
COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
automount 1939 root   28r   DIR   0,26        0 11037 /public (guinan:/u/public)
automount 1939 root   34r   DIR   0,27        0 11042 /users

Expected results:
Actual files/dirs from the filesystem, either via autofs or fstab mount, even if both are active

Additional info:
I'm adjusting this workstation soon to actually use NIS and autofs, but started using the fstab mount points a few months ago.
Comment 1 Ian Kent 2009-06-13 06:10:11 EDT
(In reply to comment #0)
> Description of problem:
> automount blocks NFS mount points in fstab
> 
> Version-Release number of selected component (if applicable):
> autofs-5.0.4-28.x86_64
> 
> How reproducible:
> Always, since sometime during F11's rawhide anyway.
> 
> Steps to Reproduce:
> 1.add fstab entries for nfs, pointing to nis server
> 2.(not really sure if the combined nfs/nis server is key)
> 3.reboot, with autofs service enabled
> 
> Actual results:
> NFS filesystems are mounted, but unavailable:
> 
> [root@jerry-opti755 ~]# mount | grep nfs
> sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
> stpftp:/home/exports/mirrors/centos on /opt/pub/mirrors/centos type nfs
> (ro,addr=10.111.1.244)
> guinan:/u/public on /public type nfs (rw,addr=10.111.1.61)
> guinan:/users on /users type nfs (rw,addr=10.111.1.61)
> [root@jerry-opti755 ~]# ls /users /public
> /public:
> 
> /users:
> [root@jerry-opti755 ~]# lsof +d /users /public
> lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/jerry/.gvfs
>       Output information may be incomplete.
> COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF  NODE NAME
> automount 1939 root   28r   DIR   0,26        0 11037 /public
> (guinan:/u/public)
> automount 1939 root   34r   DIR   0,27        0 11042 /users
> 
> Expected results:
> Actual files/dirs from the filesystem, either via autofs or fstab mount, even
> if both are active
> 
> Additional info:
> I'm adjusting this workstation soon to actually use NIS and autofs, but started
> using the fstab mount points a few months ago.  

I don't understand what the problem is here?

You can't have an entry mounted from the fstab, then specify the
same mount point as managed by autofs, and somehow expect autofs
to mount over the top of it and not cover it. It's never worked
that way.

How about you post the autofs maps your trying to use and we'll
see if we can understand what it is you trying to describe.

Ian
Comment 2 Jerry Amundson 2009-07-02 09:55:33 EDT
I had assumed the network had no auto maps in place, but realized this was not the case when looked on the NIS server. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.