Bug 505626 - s390x installer db error
s390x installer db error
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
wes hayutin
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-06-12 12:03 EDT by wes hayutin
Modified: 2009-08-20 15:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 09:52:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-12 12:03:14 EDT
Description of problem:

6/12 build remote db selinux enforcing


The Database has schema.  Would you like to clear the database [Y]? Y
** Database: Clearing database.
** Database: Shutting down services that may be using DB: [tomcat5, taskomatic, httpd, jabberd, osa-dispatcher, tsdb_local_queue].
** Database: Services stopped.  Clearing DB.
DBD::Oracle::st execute failed: ORA-00054: resource busy and acquire with NOWAIT specified (DBD ERROR: error possibly near <*> indicator at char 11 in 'drop TABLE <*>RHNPUSHCLIENT cascade constraints') [for Statement "drop TABLE RHNPUSHCLIENT cascade constraints"] at /usr/lib/perl5/vendor_perl/5.8.8/Spacewalk/Setup.pm line 443, <STDIN> line 1.
Issuing rollback() for database handle being DESTROY'd without explicit disconnect(), <STDIN> line 1.


recreate:
1. install s390x sat530 remote db
2. kickstart server and install one more time to remote db

get above error
Comment 1 wes hayutin 2009-06-12 12:04:52 EDT
could not recreate, probably a one time issue
Comment 2 Devan Goodwin 2009-06-18 09:52:46 EDT
Can't reproduce either. 

Michael Mraka commented in email:

"That's what you get if you try to rerun the installation while there are some
residual processes connected to the database. Bouncing the database should be
enough."

Closing for now.

Note You need to log in before you can comment on or make changes to this bug.