Bug 50564 - function wctomb shouldn't crash if wchar passed to it is negative
function wctomb shouldn't crash if wchar passed to it is negative
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 05:38 EDT by hvv
Modified: 2006-08-04 16:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:23:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description hvv 2001-08-01 05:38:23 EDT
Description of Problem: In a lot of lame code, char (that is signed) is passed directly as argument to wctomb - so it gets negative argument. Glibc shipped with RH7.1 crashes when this happens.


How Reproducible: Try to start gnumeric 0.67 under russian locale or write a small testsuite yourself.


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jakub Jelinek 2001-08-07 09:16:39 EDT
Could reproduce this up to glibc-2.2.3-18, cannot reproduce it with glibc-2.2.4-2.
Comment 2 Bill Nottingham 2006-08-04 16:23:36 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.