Bug 505644 - xrandr fails to be able to rotate screen
xrandr fails to be able to rotate screen
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server-utils (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 14:10 EDT by Suzanne Hillman
Modified: 2009-09-16 16:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 16:58:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2009-06-12 14:10:15 EDT
Description of problem:
xrandr fails to work to rotate screen on Toshiba Portege (intel). 

Version-Release number of selected component (if applicable):
xorg-x11-server-utils-7.1-4.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL5.4-Client-20090608.2
2. Run "xrandr -o inverted --verbose" while in X.
  
Actual results:
[root@localhost ~]# xrandr -o inverted --verbose
 SZ:    Pixels          Physical       Refresh
*0   1024 x 768    ( 346mm x 260mm )  *60
 1    800 x 600    ( 346mm x 260mm )   60   56
 2    640 x 480    ( 346mm x 260mm )   60
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none
Setting size to 0, rotation to inverted
Setting reflection on neither axis
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  156 (RANDR)
  Minor opcode of failed request:  2 (RRSetScreenConfig)
  Serial number of failed request:  12
  Current serial number in output stream:  12


Expected results:
Should rotate!

Additional info:
Not a regression.
Comment 1 Suzanne Hillman 2009-06-12 14:24:50 EDT
This originally was noticed on a Toshiba Portege with Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller.

Based on https://bugzilla.redhat.com/show_bug.cgi?id=184877 it looks like this is actually supposed to be working.

Anyone know expected current state for this?
Comment 2 Adam Jackson 2009-09-16 16:58:51 EDT
This isn't expected to work in RHEL5.  That's why "inverted" isn't in the list of possible reflections.

Note You need to log in before you can comment on or make changes to this bug.