Bug 505656 - File -i produces strange results for MS Office 2007 files.
File -i produces strange results for MS Office 2007 files.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: file (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Kaluža
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 15:08 EDT by Tyler Bannister
Modified: 2012-10-31 05:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: file-4.17-17
Doc Type: Bug Fix
Doc Text:
Cause: application/msword mime-type was listed twice in DOC/XLS magic patterns. Consequence: File printed "application/msword" mime-type twice. Fix: The second mime-type definition have been removed. Result: File prints application/msword only once.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:45:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tyler Bannister 2009-06-12 15:08:19 EDT
Description of problem:
When running file -i against MS Office 2007 files file returns duplicate identifiers like:
my.doc: application/msword application/msword

Version-Release number of selected component (if applicable):
file-4.17-15.el5_3.1

How reproducible:
Always

Steps to Reproduce:
1. Use MS Office 2007 to save a file in 2007 native or 2003 format.
2. scp file to server.
3. run file -i on file
  
Actual results:
file -i outputs:
my.doc: application/msword application/msword

Expected results:
file -i outputs:
my.doc: application/msword

Additional info:
I've confirmed that the bug is affecting at least 3 of my servers.  It may be the reappearance of an old bug: 249578
Comment 1 Daniel Novotny 2009-06-15 04:53:17 EDT
(In reply to comment #0)
> It may be
> the reappearance of an old bug: 249578  
yes, it is, because bug #249578 was fixed only in Fedora, but not in RHEL 5
Comment 2 Daniel Novotny 2009-10-09 08:31:55 EDT
this issue is solved by removing an old "file-4.17-powerpoint.patch"
Comment 5 RHEL Product and Program Management 2010-08-09 14:26:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 Jan Kaluža 2012-01-05 07:12:33 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: application/msword mime-type was listed twice in DOC/XLS magic patterns.

Consequence: File printed "application/msword" mime-type twice.

Fix: The second mime-type definition have been removed.

Result: File prints application/msword only once.
Comment 10 errata-xmlrpc 2012-02-21 00:45:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0201.html

Note You need to log in before you can comment on or make changes to this bug.