Bug 505659 - Clicking on desktop hides notes - bad UI mentality
Clicking on desktop hides notes - bad UI mentality
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 15:23 EDT by Michael Cronenworth
Modified: 2010-03-23 14:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 14:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove desktop hiding functionality (1.15 KB, patch)
2009-06-12 15:23 EDT, Michael Cronenworth
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 315508 None None None Never

  None (edit)
Description Michael Cronenworth 2009-06-12 15:23:43 EDT
Created attachment 347649 [details]
remove desktop hiding functionality

Description of problem: Clicking on the desktop hides your notes. Any accidental clicks will make all your notes disappear! I can't tell you how many times I've let out profanity for such non-sense. All my peers agree.


Version-Release number of selected component (if applicable): gnome-applets-2.26.1-3.fc11


Additional info: The attached patch removes the click-on-desktop-to-hide-notes functionality. I've sent it upstream, but I have no hope that they will incorporate it as the bug for it as been open for 3 years. The patch is against gnome-applets-2.26.1-3.fc11 and I have made local RPMs on my system just in case Fedora refuses the patch as well.
Comment 1 Michael Cronenworth 2009-07-28 09:24:04 EDT
What do I have to do to get some attention on this bug?

I noticed there was an upstream bug on Sticky Notes that was fixed in the gnome-applets update last week. My fix has gone completely unnoticed by all parties. I've had to rebuild the Fedora RPM with my patch twice. Not looking forward to three times.
Comment 2 Ray Strode [halfline] 2009-07-30 10:26:52 EDT
Hi Michael,

Sorry for the slow response on this bug report.

I don't think this is a patch we would want to carry without upstream buy in.

What's the upstream bug number?
Comment 3 Michael Cronenworth 2009-07-30 11:27:52 EDT
Sorry about that. I thought I had the external bug attached. It should be now. If not, it's here: http://bugzilla.gnome.org/show_bug.cgi?id=315508

After re-reading it looks like three/four bugs in one so that may be the cause of the confusion and 3 year delay...
Comment 4 Michael Cronenworth 2010-03-23 14:19:37 EDT
This functionality was retracted upstream in 2.28, but in order to even use stickynotes in current Fedora, you have to apply the patch from bug 574696.

Note You need to log in before you can comment on or make changes to this bug.