Bug 505676 - no way to handle pass-through audio (line-in -> line-out)
no way to handle pass-through audio (line-in -> line-out)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 17:12 EDT by Stig Hackvan
Modified: 2009-09-22 09:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 11:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2009-06-12 17:12:41 EDT
Description of problem:

the abandonment of the old gnome-mixer (F11) and replacement with a pulse-audio-centric audio setup has screwed up the use-case where multiple computers share speakers via line-in pass-through.

this has been discussed/flamed already, but i couldn't find a bug report.

basically, what I use all the time and really do need is support in the gui for passing input channels through to line-out.  I use this both for supporting audio from a 2nd pc, and also to monitor inputs when recording.

this is functionality that has been present since the dawn of time and i'm highly troubled (after seeing the flames online) that fedora would discard this capability so callously.


so here i'm recycling some of the existing mailing list flames:

http://www.linux-archive.org/fedora-development/286596-fedora-11-nerfed-my-mixer.html
 

http://osdir.com/ml/fedora-devel-list/2009-04/msg01844.html

Re: Fedora 11 nerfed my mixer: msg#01844
fedora-devel-list
Subject: 	Re: Fedora 11 nerfed my mixer

On Thu, 2009-04-23 at 17:31 +0200, Lennart Poettering wrote:
> Still I think that playing audio through line-in a pretty exotic
> feature. If you want to do weird stuff like this, go to the ALSA
> mixer. It's not that PA takes that away from you. You can always
> bypass PA if you really feel that you need 555 different controls.

Yes, monitoring what you're recording on the line in is SUCH an unusual
need! Just think of what I'm doing as monitoring a recording without
actually recording.

If you want Pulseaudio to ever be more than a toy for Aunt Tillie,
you're going to have to pull your head out of your ass.

> > I can't play DVDs through my TV from my laptop at the moment either --
> > the only way I could get sufficient volume before was to plug in some
> > external speakers (which automatically turns off the internal speakers)
> > and then use gnome-volume-control to turn the internal speakers back
> > _on_ again. I can't do that any more.
>
> You can, just bypass PA.
>
> If you want to do weird stuff, use weird tools. Don't expect us to
> support all the exotic use cases minds could come up with to support
> in a single simple UI.
>
> > The proposals I've seen to work around PulseAudio's problems have been
> > ridiculous -- running audio over the network using PulseAudio,
> > introducing a bunch of latency which wouldn't otherwise be there, was a
> > stupid suggestion even if the other box wasn't running Windows. The
> > hardware has a line-in socket for a reason -- are we just going to
> > advise Fedora users to tape over it and pretend it isn't there?
>
> The point of line-in is that you can record from it.
>
> Doing line-in/mic feedback to line-out is something I deliberetaly don't
> plan to support in PA.

It's called "input monitoring" and it's not unusual. Why is someone with
no apparent musical or audio recording background in charge of core
Fedora audio infrastructure?

> A sound card is not an amp.

I don't want it to amplify, in fact that's exactly what I don't want. I
just want it to pass line-in through to the amplified speakers as
untouched as possible. I want 0dB. How many different ways do I have to
explain this before you get it?

[...]


> This whole thread is so pointless. The same people just keep repeating
> the same issues over and over.

Because you and Bastien Nocera are being defensive, stubborn
thick-headed dicks who aren't listening. Yes, we get it. Disagreeing
with the almighty Lennart Poettering is a pointless waste of time. Don't
bother even trying!

> Let me summarize this:
>
> The main reason why this issue actually has become a problem recently
> is that modern cards don't do the jack switching in hw anymore but leave
> that for the software and provide jack sesning. Jack sensing is now
> supported for two chips or so in ALSA but there is no code that would
> actually make use of the jack sensing interfaces. PA should of course
> make use of it. Unfortunately none of the sound cards I posess
> currently is supported by ALSA jack sensing, so I cannot really work
> on js right now.

I've had this motherboard for 3 years. I don't give a shit what "modern"
cards do or don't do. All I want is for what worked before to continue
working.
Comment 1 paradox606 2009-09-11 12:57:41 EDT
I've been trying to listen to my ipod through my line in jack, played out of my laptop's speakers, all morning.  And its been extremely frustrating, there is no way to do it with fedora 11!  Once this bug is fixed I'll reinstall fedora, going back to an earlier release until this pulse audio bug is resolved.
Comment 2 Bastien Nocera 2009-09-18 11:36:01 EDT
Stig, insulting developers and being rude certainly won't help us care about your use case.

I plugged in my iPod, selected my computer's internal sound card as the default input, checked that sound was coming through it on the selected connector.

Then I launched:
arecord | aplay

And it outputted the sound to my speakers. The sound was of poor quality and saturated, but I'm sure there's a better way to do that with PulseAudio.

Then I'm sure somebody could write a simple app where you'd choose the input and the output and connect the 2 without recording (through the monitor API of PulseAudio, or using pulsesrc/pulsesink in GStreamer).

(PS: we don't use votes)
Comment 3 Lennart Poettering 2009-09-18 11:41:12 EDT
We never took away any features. You can still do that with a line like:

amixer -c0 sset Line 100% on

In fact, PA nowadays allows digital playback monitoring too, by loading "module-loopback". Doing this will allow you to have a PCI card monitor input from an USB card which the analog path does not allow you to do.

So, let me stress this: we have not taken away any monitoring-related features, no, in fact we have extended them.

However -- we don't expose it in the UI. Playback monitoring is not really something we want to show, because it is an exotic feature. I know that some disagree on that, but uh, we have to agree to disagree on that.
Comment 4 Lennart Poettering 2009-09-18 11:42:28 EDT
(In reply to comment #2)
> Stig, insulting developers and being rude certainly won't help us care about
> your use case.
> 
> I plugged in my iPod, selected my computer's internal sound card as the default
> input, checked that sound was coming through it on the selected connector.
> 
> Then I launched:
> arecord | aplay

Due to latency/time deviation issues, using module-loopback inside of PA is probably a better idea.
Comment 5 Bastien Nocera 2009-09-18 12:03:52 EDT
Indeed, works much better using:
pacmd load-module module-loopback sink=470 source=732

The magic numbers are the index of the source and sinks. You can get them using "pacmd list-sources" and "pacmd list-sinks" respectively. Somebody could write a small app that does that using drop-downs for each source/sink and connecting them, and showing a level meter.
Comment 6 Lennart Poettering 2009-09-18 12:09:18 EDT
(In reply to comment #5)
> Indeed, works much better using:
> pacmd load-module module-loopback sink=470 source=732
> 
> The magic numbers are the index of the source and sinks. You can get them using
> "pacmd list-sources" and "pacmd list-sinks" respectively. Somebody could write
> a small app that does that using drop-downs for each source/sink and connecting
> them, and showing a level meter.  

Instead of tracking down the magic numbers you could just load the module without specifiying anything and the move the streams to the right sink/source via pavucontrol.
Comment 7 Bastien Nocera 2009-09-18 12:24:07 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > Indeed, works much better using:
> > pacmd load-module module-loopback sink=470 source=732
> > 
> > The magic numbers are the index of the source and sinks. You can get them using
> > "pacmd list-sources" and "pacmd list-sinks" respectively. Somebody could write
> > a small app that does that using drop-downs for each source/sink and connecting
> > them, and showing a level meter.  
> 
> Instead of tracking down the magic numbers you could just load the module
> without specifiying anything and the move the streams to the right sink/source
> via pavucontrol.  

Except that you'd get feedback. Nearly made my ears bleed when the 5.1 speakers were feeding back into the webcam's mike...
Comment 8 Stig Hackvan 2009-09-21 18:58:50 EDT
Bastien, I wasn't insulting developers, I was quoting a flame (url included) between Lennart & some other fellow what was making a lot of noise about the removed functionality during the F11 pre-release cycle.  Now F12 is approaching and Fedora is still calling this removed functionality is "not a bug" and "wontfix" (oh, excuse me...really, it's buried-so-deep-that-only-the-hardcore-can-find-it)...

Still I differ.  I filed this bug because I could see the trail of flames on the net (quoted) but not a bug report.

The loss of functionality was such an irritation to me that I stopped tracking fedora because of the new inconvenience.  I'm not the only one...it seems that  paradox606@nc.rr.com shares my sense of "acute disappointment" over this abandoned support in the UI (heck, the Windows UI let's me patch line-in through to the output channel...no command-line incantations required there...) for basic audio functionality.

THIS CHANGE IS A *REGRESSION*!  It is NOT "progress"...  And what's sorely disappointing about attempting to participate in the open source process is that so often such efforts are rebuffed with a wholesale disregard for the user experience.  Bugzilla conversations occasionally bring me workarounds and coping strategies, but I very seldomly see fixes come out of them.  

It is truly depressing.

ps: my .bashrc is huge and I have no qualms with the command line, but in order to patch line-in to line-out, there's no way you can convince me that digging around in the command line, loading kernel/pulseaudio modules with carefully-researched arguments is the "right way" to do it.

This IS A BUG!
Comment 9 Bastien Nocera 2009-09-22 09:50:17 EDT
(In reply to comment #8)
> Bastien, I wasn't insulting developers, I was quoting a flame (url included)

How is that any better? You're quoting insults, does that make it alright?

> between Lennart & some other fellow what was making a lot of noise about the
> removed functionality during the F11 pre-release cycle.  Now F12 is approaching
> and Fedora is still calling this removed functionality is "not a bug" and
> "wontfix" (oh, excuse me...really, it's
> buried-so-deep-that-only-the-hardcore-can-find-it)...

It's not hidden any further than it used to be. You can still use gst-mixer to enable the feature.

> Still I differ.  I filed this bug because I could see the trail of flames on
> the net (quoted) but not a bug report.
> 
> The loss of functionality was such an irritation to me that I stopped tracking
> fedora because of the new inconvenience.  I'm not the only one...it seems that 
> paradox606@nc.rr.com shares my sense of "acute disappointment" over this
> abandoned support in the UI (heck, the Windows UI let's me patch line-in
> through to the output channel...no command-line incantations required there...)
> for basic audio functionality.

The support is still there in gst-mixer if you require it.

> THIS CHANGE IS A *REGRESSION*!  It is NOT "progress"...  And what's sorely
> disappointing about attempting to participate in the open source process is
> that so often such efforts are rebuffed with a wholesale disregard for the user
> experience.  Bugzilla conversations occasionally bring me workarounds and
> coping strategies, but I very seldomly see fixes come out of them.  

It's not a regression, the support was in an application that's still available. The feature is still available, and you can even make it sound better than it used to by using PulseAudio's feature.

> It is truly depressing.

It's truly depressing that nobody started working on a UI for it when I've explained what's needed, instead of wrongly complaining that it's a regression.

> ps: my .bashrc is huge and I have no qualms with the command line, but in order
> to patch line-in to line-out, there's no way you can convince me that digging
> around in the command line, loading kernel/pulseaudio modules with
> carefully-researched arguments is the "right way" to do it.

I said "the right way", because it doesn't eat as much CPU, or sound worse than "arecord | aplay" would.

And you don't need to load any kernel modules.

> This IS A BUG!  

It's not. It's a feature request. Given the explanations above, I'll reiterate that you won't see this feature in gnome-volume-control, but that you could implement a UI for it reusing parts of gnome-volume-control's code.

Note You need to log in before you can comment on or make changes to this bug.