Bug 505677 - "cataddr: string too long" error receiving mail from certain Exchange servers
"cataddr: string too long" error receiving mail from certain Exchange servers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sendmail (Show other bugs)
4.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
http://www.mmmug.co.uk/blogs/nweb/arc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 17:21 EDT by advax
Modified: 2010-04-21 08:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 08:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description advax 2009-06-12 17:21:48 EDT
Description of problem:

When email is received from certain servers (in our case, 2 regular partners running Microsoft Exchange), it is rejected. syslog shows "cataddr: string too long"

Version-Release number of selected component (if applicable):
sendmail-8.13.1-3.3.el4.i386

How reproducible:
100%

Steps to Reproduce:
1. Email to a user at the remote site who has an out-of-office autoreply
2. Wait for reply
3.
  
Actual results:
Mail not delivered, remote user gets rejection message, syslog shows
catadr error

Expected results:
Mail arrives

Additional info:
sendmail.org shows some information relating to this bug in the changelog for sendmail 8.13.2.
sendmail 8.13.8-2 built from RHEL 5.3 SRPM does not have the problem
The problem only happened for us when using TLS which was negotiated during SMTP.
If I disabled TLS, the problem did not occur. I was then able to capture the SMTP packets, but could see no formatting problem with the message - no bare CR, no long lines. Replaying the message
through openssl s_client starttls did not trigger the problem. The only odd
(but legitimate) feature was that the message body (nominally English text) was base-64 encoded UTF-8
So I do not understand why the error occurs, only that upgrading sendmail beyond the last RHEL4 version cures the problem.

I have no way to reproduce the problem apart from corresponding with users at the 2 sites in question.
Comment 1 Petr Ruzicka 2010-01-13 10:45:26 EST
I have the same problem.

It looks like it's fixed in Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=131179

It's fixed in sendmail 8.13.2 (http://www.sendmail.org/releases/8.13.2)
Comment 2 Petr Ruzicka 2010-01-19 10:42:36 EST
This is probably problem in MS Exchange configuration:

http://www.mmmug.co.uk/blogs/nweb/archive/2009/03/28/26631.aspx 

I can't verify it...

See you

PetrR
Comment 3 Jaroslav Škarvada 2010-04-21 06:47:39 EDT
The cataddr error is caused by TLS negotation phase between Exchange and Sendmail. 

There is upstream errata (2004-08-24) and patch available for cataddr errors:
http://www.sendmail.org/releases/8.13.1
http://www.sendmail.org/patches/parseaddr.c.cataddr.8.379

This patch was also merged to sendmail-8.13.2 by upstream and I assume it is the same piece of code as described in sendmail-8.13.2 changelog mentioned in comment #1.

This patch is applied from sendmail-8.13.1-2.el4 up, thus this error couldn't appear. Please could you reinstall sendmail-8.13.1-3.3.el4 and recheck?
Comment 4 Petr Ruzicka 2010-04-21 07:38:29 EDT
Hello.

I can still see this error messages in my logs, but as you wrote - it caused by MS Exchange.

I'm using sendmail-8.13.1-3.3.el4 and I can't reinstall it.

As far as I remember MS Exchnage can be configured to work well with Sendmail using TLS negotiation so you can close this ticket.

Thank you

PetrR
Comment 5 Jaroslav Škarvada 2010-04-21 08:12:01 EDT
OK, thank you, closing.

Note You need to log in before you can comment on or make changes to this bug.