Bug 505684 - flyspell-mode fails with mail-mode with message-signature-separator not defined
flyspell-mode fails with mail-mode with message-signature-separator not defined
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 18:03 EDT by Phil Smith
Modified: 2009-09-16 05:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 05:07:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Smith 2009-06-12 18:03:53 EDT
Description of problem:
flyspell-mode fails to work in mail-mode and the error "Error in post-command-hook: (void-variable message-signature-separator)"

Version-Release number of selected component (if applicable):
emacs-22.3-11.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. emacs junk.txt
2. M-x mail-mode
3. M-x flyspell-mode
4. type junk words
5. flyspell doesn't work
  
Actual results:
flyspell doesn't work

Expected results:
flyspell should work

Additional info:
flyspell works when not in mail-mode

If I put
    (defvar message-signature-separator "^-- *$" "\
    Regexp matching the signature separator.")
in .emacs, it works.
So it looks like message-signature-separator is not defined anywhere.
And a grep of the *.el supports this.
Comment 1 Phil Smith 2009-07-14 05:15:25 EDT
Opened emacs bug:
  http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=3837
Response: "This was fixed last year (will be in 23.1)."
Comment 2 Phil Smith 2009-09-16 04:27:29 EDT
Yum update updated emacs to 23.1 and problem fixed.
Can close.
Comment 3 Daniel Novotny 2009-09-16 05:07:05 EDT
OK, closing

Note You need to log in before you can comment on or make changes to this bug.