Bug 505702 - hts 5.3 fails to detect CDROM device during certification on RHEL 4.8 x86-64
hts 5.3 fails to detect CDROM device during certification on RHEL 4.8 x86-64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rob Landry
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 21:15 EDT by Kristopher Huynh
Modified: 2014-03-25 20:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-13 10:28:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results from the hts runs with the failing CDROM test (329.91 KB, text/plain)
2009-06-12 21:15 EDT, Kristopher Huynh
no flags Details

  None (edit)
Description Kristopher Huynh 2009-06-12 21:15:12 EDT
Created attachment 347691 [details]
Results from the hts runs with the failing CDROM test

Description of problem:
I am certifying VMware ESX Server 4.0 with RHEL 4.8 x86-64 as the guest OS. The hts CDROM test keeps failing because it cannot detect the CDROM device. However, I installed RHEL 4.8 with this same CDROM device, and I can manually mount a CD (a RHEL install CD) and read data from the CD. So, RHEL can see and read the CDROM device, but the hts test suite does not appear to be able to.

When I run the hts CDROM test without a CD already mounted, I get an error message about no CDROM device detected. When I run it again with a CD mounted, I get error messages about the CDROM test itself. I've attached the results.xml file.

As an aside, I completed certification with RHEL 5.3 on this same machine with the same version of ESX and the hts CDROM test passed with no issue.

Version-Release number of selected component (if applicable):
hts-5.3-17.el4

How reproducible:
Always reproducible.

Steps to Reproduce:
1. Install ESX Server 4.0 on a physical server with a CDROM drive.
2. Create a new virtual machine with RHEL 4.8 x86-64 as the guest OS.
3. Install hts.
4. Run the hts CDROM test.
  
Actual results:
The hts CDROM test fails.

Expected results:
The hts CDROM test should pass.

Additional info:
Comment 1 Kristopher Huynh 2009-06-15 18:19:22 EDT
This issue also occurs in hts on RHEL 4.8 i386.
Comment 4 Rob Landry 2011-12-12 11:11:23 EST
A good portion of the cd support code has changed since this issue was reported.  Does this issue still exist in the current v7-1.4?
Comment 5 Akash Kodenkiri 2011-12-12 23:00:22 EST
No, Issue not exist on latest Cert Kit v7-1.4 We can close this bug.

-Akash
Comment 6 Rob Landry 2011-12-13 10:28:08 EST
Excellent news.  I'll go ahead and close this bug.

Note You need to log in before you can comment on or make changes to this bug.