Bug 505713 - description of applydeltaiso command in its man page is wrong
description of applydeltaiso command in its man page is wrong
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: deltarpm (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 23:14 EDT by Andre Robatino
Modified: 2009-07-27 12:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 12:03:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2009-06-12 23:14:49 EDT
Description of problem:
In the applydeltaiso man page, the description says

NAME
       applydeltaiso - create a deltaiso from two isos

which is the correct description for makedeltaiso but not applydeltaiso.  It should say something like "create an output iso from an input iso and a deltaiso".

Version-Release number of selected component (if applicable):
deltarpm-3.4-16.fc11
Comment 1 Andre Robatino 2009-06-12 23:31:10 EDT
The exact same mistake is (not surprisingly, since both man pages are dated Feb. 2005) in Rawhide, deltarpm-3.4-16.fc12.  Should this be cloned or just change its Version to rawhide?
Comment 2 Jonathan Dieter 2009-06-19 14:13:00 EDT
Go ahead and leave it as is.  I'll take care of it for both (though it will probably take longer for the F11 update to come through).
Comment 3 Andre Robatino 2009-06-19 16:50:53 EDT
While you're at it, there's a trivial spelling mistake in applydeltaiso (I mentioned it in an email to Michael Schroeder but never heard back), which I'd rather not file a separate bug for.

$ strings /usr/bin/applydeltaiso | grep suce
iso sucessfully re-created, md5sum:                          <--- should be "successfully"
$
Comment 4 Jonathan Dieter 2009-07-27 12:03:03 EDT
Both fixed in deltarpm-3.5-0.git.20090727 in Rawhide, but because of other changes in deltarpm, fixes won't be backported to Fedora 11 (unless we get xz built for F11).

Note You need to log in before you can comment on or make changes to this bug.