Bug 505718 - Regression - VESA framebuffer, radeon chipset
Regression - VESA framebuffer, radeon chipset
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 00:32 EDT by Sam Varshavchik
Modified: 2010-06-28 08:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:57:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2009-06-13 00:32:31 EDT
Description of problem:

After upgrading F10 to F11 (2.6.27.24-170.2.68.fc10 to 2.6.29.4-167.fc11) the VESA framebuffer console no longer works.

The laptop boots succesfully, however without a working VESA framebuffer.

The top 1/5th (approx) of the console is now some video noise (mostly horizontal purple lines in some moire-like pattern), the lower 4/5th is a blank screen. There's some garbled animation going on in the upper 1/5th of the screen that suggests that plymouth is running and doing its thing.

Once the laptop finishes booting and x.org takes over, the system continues to function normally. x.org initializes the video chipset, and proceeds to run as usual.

Version-Release number of selected component (if applicable):

Linux laptop.email-scan.com 2.6.29.4-167.fc11.i586 #1 SMP Wed May 27 17:14:37 EDT 2009 i686 i686 i386 GNU/Linux

How reproducible:

Always

Steps to Reproduce:

Upgraded F10 to F11 on a laptop with the following video chipset:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 01) (prog-if 00 [VGA controller])
        Subsystem: Uniwill Computer Corp Device 2301
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 64 (2000ns min), Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at b000 [size=256]
        Region 2: Memory at ffcf0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at ffcc0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
                Status: RQ=48 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x4
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: radeon

Actual results:

Garbled VESA console

Expected results:

Plymouth runs at system boot, get to watch some pretty solar flares, until the system is ready.

Additional info:

F10 used to boot this laptop with the "vga=791" kernel boot parameter (VESA 1024x768x16). Under F11, this results in a broken VESA framebuffer.

Also tried "vga=792" (VESA 1024x768x24) and "vga=788" (VESA 800x600x16) with similar results, differing only in the visual attributes of the garbage (slightly bigger or smaller, different color).

I then tried "vga=3847 (VGA 80x60, according to "vga=ask") and the kernel booted with a working console, and working plymouth visual effects. So I have an apparent workaround, however it's not 100%. When I initiate shutdown from Gnome, x.org quits and I'm returned to the last plymouth frame, I do not see the expected initscripts messages when the system is shutting down.

Note -- the above vga modes are decimal (vga=ask lists them in hex).
Comment 1 Jérôme Glisse 2009-10-14 06:56:10 EDT
With kernel modesetting don't use VESA framebuffer, we haven't yet forbidden this to happen but it's know to not work and won't work. But you will get native resolution console with kernel modesetting. I am going to close this bug.
Comment 2 Bug Zapper 2010-04-27 10:51:25 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2010-06-28 08:57:33 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.