Bug 505719 - virt-manager fails to reboot guests
virt-manager fails to reboot guests
Status: CLOSED DUPLICATE of bug 496537
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 01:25 EDT by bodhi.zazen
Modified: 2009-06-15 06:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 06:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bodhi.zazen 2009-06-13 01:25:58 EDT
Description of problem: Virtmanager fails to reboot guest.


Version-Release number of selected component (if applicable):

From your wiki page 

rpm -q kvm python-virtinst virt-viewer virt-manager
package kvm is not installed
python-virtinst-0.400.3-8.fc11.noarch
virt-viewer-0.0.3-4.fc11.x86_64
virt-manager-0.7.0-5.fc11.x86_64

I suspect you want this (perhaps update wiki ;) )

rpm -q qemu-kvm
qemu-kvm-0.10.4-4.fc11.x86_64

How reproducible: Always


Steps to Reproduce:
1. In the guest Virtual Machine -> Shutdown -> Reboot
2. In virt-manager Right click guest name -> shutdown -> reboot
  
Actual results:

Error message :
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 523, in reboot_domain
    vm.reboot()
  File "/usr/share/virt-manager/virtManager/domain.py", line 569, in reboot
    self.vm.reboot(0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 392, in reboot
    if ret == -1: raise libvirtError ('virDomainReboot() failed', dom=self)
libvirtError: this function is not supported by the hypervisor: virDomainReboot



Expected results: Reboot guest


Additional info:

1. Error persists even if selinux is disabled.

2. Error message in log :

tail -F /var/log/messages

libvirtd: 23:19:34.302: error : this function is not supported by the hypervisor: virDomainReboot

tail -F /var/log/libvirt/qemu/guest.log

Nothing.

2. Shutdown does nothing , guest still running, no error message.

3. Force off -> error message / warning -> restart guest is only option.
Comment 1 Daniel Berrange 2009-06-15 06:27:44 EDT

*** This bug has been marked as a duplicate of bug 496537 ***

Note You need to log in before you can comment on or make changes to this bug.