Bug 505722 - Windows Sync: AD-Groups with a mail address are not synchronised
Windows Sync: AD-Groups with a mail address are not synchronised
Status: CLOSED CURRENTRELEASE
Product: Red Hat Directory Server
Classification: Red Hat
Component: winsync (Show other bugs)
8.1
All Linux
medium Severity low
: DS8.2
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
: 527805 (view as bug list)
Depends On:
Blocks: 639035 389_1.2.8
  Show dependency treegraph
 
Reported: 2009-06-13 04:01 EDT by Karan Rai
Modified: 2016-05-06 10:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-06 10:37:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (3.48 KB, patch)
2011-01-13 17:27 EST, Nathan Kinder
nhosoi: review+
Details | Diff

  None (edit)
Comment 2 Rich Megginson 2009-10-07 15:23:27 EDT
There is a simple workaround.  The file 50ns-directory.ldif in the
/etc/dirsrv/slapd-instance/schema directory defines the ntGroup objectclass.

1) Copy the definition of ntGroup from that file into 99user.ldif
2) Edit the list of allowed attributes (the MAY list) - add mail to the list so
that the definition looks like this:
objectClasses: ( 2.16.840.1.113730.3.2.9 NAME 'ntGroup' DESC 'Netscape defined
objectclass' SUP top MUST ( ntUserDomainId ) MAY ( description $ l $ ou $
seeAlso $ ntGroupId $ ntGroupAttributes $ ntGroupCreateNewGroup $
ntGroupDeleteGroup $ ntGroupType $ ntUniqueId $ mail ) X-ORIGIN 'Netscape NT
Synchronization' )

3) restart the server
Comment 3 Rich Megginson 2009-10-07 15:25:24 EDT
*** Bug 527805 has been marked as a duplicate of this bug. ***
Comment 5 Nathan Kinder 2011-01-13 17:27:58 EST
Created attachment 473437 [details]
Patch
Comment 6 Nathan Kinder 2011-01-13 17:50:38 EST
Pushed patch to master.  Thanks to Noriko for her review!

Counting objects: 9, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (5/5), 601 bytes, done.
Total 5 (delta 4), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/ds.git
   5ebd590..7dfe817  master -> master
Comment 7 Sankar Ramalingam 2011-08-03 06:41:48 EDT
Fix verified DS90 builds.

Steps to verify:
---------------
1. Configure Winsync and add a group to AD with mail attribute as this.

dn: CN=bug505722_1,OU=pass_sync,DC=win2k8sync64,DC=com
objectClass: top
objectClass: group
cn: bug505722_1
distinguishedName: CN=bug505722_1,OU=pass_sync,DC=win2k8sync64,DC=com
name: bug505722_1
sAMAccountName: bug505722_1
groupType: 2
objectCategory: CN=Group,CN=Schema,CN=Configuration,DC=win2k8sync64,DC=com
mail: sramling_1@redhat.com

2. Check whether the group is synced to DS.
 Host=`hostname`;Port=1389;Base="dc=pass_sync,dc=com"; /usr/lib64/mozldap/ldapsearch -h $Host -p $Port -D "cn=Directory Manager" -w "Secret123" -b "$Base" "cn=bug505722_*"

dn: cn=bug505722_2,dc=pass_sync,dc=com
objectClass: top
objectClass: groupofuniquenames
objectClass: ntGroup
ntGroupDeleteGroup: true
cn: bug505722_2
ntUserDomainId: bug505722_2
ntGroupType: 2
mail: sramling_2@redhat.com
ntUniqueId: ffb5f438c7811c46b867e0edfa39e5a5
Comment 8 Sankar Ramalingam 2011-08-03 08:03:12 EDT
Fix verified DS90 builds.

Steps to verify:
---------------
1. Configure Winsync and add a group to AD with mail attribute as this.

dn: CN=bug505722_1,OU=pass_sync,DC=win2k8sync64,DC=com
objectClass: top
objectClass: group
cn: bug505722_1
distinguishedName: CN=bug505722_1,OU=pass_sync,DC=win2k8sync64,DC=com
name: bug505722_1
sAMAccountName: bug505722_1
groupType: 2
objectCategory: CN=Group,CN=Schema,CN=Configuration,DC=win2k8sync64,DC=com
mail: sramling_1@redhat.com

2. Check whether the group is synced to DS.
 Host=`hostname`;Port=1389;Base="dc=pass_sync,dc=com"; /usr/lib64/mozldap/ldapsearch -h $Host -p $Port -D "cn=Directory Manager" -w "Secret123" -b "$Base" "cn=bug505722_*"

dn: cn=bug505722_2,dc=pass_sync,dc=com
objectClass: top
objectClass: groupofuniquenames
objectClass: ntGroup
ntGroupDeleteGroup: true
cn: bug505722_2
ntUserDomainId: bug505722_2
ntGroupType: 2
mail: sramling_2@redhat.com
ntUniqueId: ffb5f438c7811c46b867e0edfa39e5a5

Note You need to log in before you can comment on or make changes to this bug.