Bug 505727 - bacula console and bacula wxconsole don't start from menus
bacula console and bacula wxconsole don't start from menus
Status: CLOSED DUPLICATE of bug 426790
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 05:26 EDT by Stephanos Manos
Modified: 2009-07-22 12:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 12:39:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephanos Manos 2009-06-13 05:26:33 EDT
When trying to run Bacula Console from the menus nothing happens.
When trying to run Bacula WX Console from the menus i get an error window saying "Failed to find selected program.".

When trying to run Bacula Console from cli as a user with "bgnome-console -c /etc/bacula/bgnome-console.conf" (as stated in the .desktop file) i get the following 

13-Jun 11:55 bgnome-console: ERROR TERMINATION at parse_conf.c:829
Config error: Cannot open config file "/etc/bacula/bgnome-console.conf": Permission denied

If i rename /usr/bin/gnome-console to /usr/bin/bgnome-console it works as expected.

As for Bacula WX Console the problem is with the /etc/security/console.apps/wxconsole. This file is a .desktop file and not a console.apps file.
If i change the contents to

USER=root
PROGRAM=/usr/sbin/bwxconsole
SESSION=true

Then it works as expected.

BTW bat although is working has the same problem with the console.apps file.
Comment 1 Jon Ciesla 2009-07-22 12:39:53 EDT

*** This bug has been marked as a duplicate of bug 426790 ***

Note You need to log in before you can comment on or make changes to this bug.