Bug 505736 - Suspend/Hibernate problem kernel 2.6.18-153.el5
Suspend/Hibernate problem kernel 2.6.18-153.el5
Status: CLOSED DUPLICATE of bug 505541
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
high Severity high
: beta
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
: Regression
Depends On:
  Show dependency treegraph
Reported: 2009-06-13 06:15 EDT by Toshaan Bharvani
Modified: 2013-01-10 02:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-22 12:21:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
panic at end of hibernate. (337.61 KB, image/jpeg)
2009-06-17 15:08 EDT, Mike Gahagan
no flags Details

  None (edit)
Description Toshaan Bharvani 2009-06-13 06:15:49 EDT
Description of problem:
Notebook (ThinkPad) doesn't come out of suspend/hibernate with kernel 2.6.18-153.el5 64bit and 32bit are affected

Version-Release number of selected component (if applicable):
kernel 2.6.18-153.el5 : x86_64 and i686 versions

How reproducible:

Steps to Reproduce:
1. Download and install kernel 2.6.18-153.el5 from http://people.redhat.com/dzickus/el5/
2a. Suspend through command line or menu
2b. Hibernate through command line or menu
3. Open notebook or press on button
4. Black TFT screen with battery light and suspend light (moon) on
Actual results:
Doesn't come out of suspend/hibernate

Expected results:
Come out of suspend/hibernate

Additional info:
kernel 2.6.18-152.el5 works normally
tests are done on a ThinkPad T60 and ThinkPad T43
seems to be related to a CPU#0 soft lockup error
Comment 1 Mike Gahagan 2009-06-17 14:44:18 EDT
I see a similar problem with a Lenovo Z61t. The machine will suspend to ram sucessfully, but will not recover. When I attempt to hibernate, right after it writes out the memory to disk, I get a panic (or possibly it is a softlockup and it scrolls off the screen). When the failure occurs the suspend indicator light on the laptop is blinking and it doesn't look like kdump will work to capture the dump. I did get a picture of the call trace which I will attach here.
Comment 2 Mike Gahagan 2009-06-17 15:08:40 EDT
Created attachment 348323 [details]
panic at end of hibernate.
Comment 6 Mike Gahagan 2009-06-18 13:34:48 EDT
The -154 kernel has resolved the suspend/hibernate issues for me. Can you try the -154 kernel to see if it resolves your issues? It is now available at:

Comment 7 Toshaan Bharvani 2009-06-19 16:45:26 EDT
Tested kernel 2.6.18-154.el5 on both my systems, ThinkPad T43 32bit and ThinkPad T60 64bit, they are suspending and hibernating back as usual. Thank you.
Comment 8 Linda Wang 2009-06-22 12:21:17 EDT

*** This bug has been marked as a duplicate of bug 505541 ***

Note You need to log in before you can comment on or make changes to this bug.