Bug 505767 - root unable to configure printer
root unable to configure printer
Status: CLOSED DUPLICATE of bug 447266
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 12:10 EDT by Daniel Qarras
Modified: 2009-06-17 08:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 08:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups access log (1.33 KB, text/plain)
2009-06-13 12:10 EDT, Daniel Qarras
no flags Details
cups error log (27.83 KB, text/plain)
2009-06-13 12:11 EDT, Daniel Qarras
no flags Details

  None (edit)
Description Daniel Qarras 2009-06-13 12:10:53 EDT
Created attachment 347746 [details]
cups access log

Description of problem:
I logged in as an ordinary user, used "su -" and launched system-config-printer from the command line as root. Seemed to work ok except a) can't access Server->Settings and b) when adding a new printer applying the changes fails due to privilege error.

Version-Release number of selected component (if applicable):
cups-1.4-0.b2.18.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1. Log in as an ordinary user
2. su -
3. system-config-printer
4. Server->Settings
5. Try to add a new printer
  
Actual results:
Permission denied for the super user(!).

Expected results:
root is able to do his will.

Additional info:
I'm attaching access_log and error_log after such an attempt.
Comment 1 Daniel Qarras 2009-06-13 12:11:15 EDT
Created attachment 347747 [details]
cups error log
Comment 2 Tim Waugh 2009-06-17 08:36:18 EDT
You don't need to become root to use system-config-printer.  Just use it from your user account.

PolicyKit denies access to the root user as a matter of course (see bug #447266).

*** This bug has been marked as a duplicate of bug 447266 ***

Note You need to log in before you can comment on or make changes to this bug.