Bug 505773 - NFS mount fails, "incorrect mount option specified
NFS mount fails, "incorrect mount option specified
Status: CLOSED DUPLICATE of bug 505018
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 12:55 EDT by Daniel Roesen
Modified: 2009-06-13 14:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-13 14:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Roesen 2009-06-13 12:55:20 EDT
[root@trinity ~]# mount -v -t nfs discworld:/scratch /scratch
mount.nfs: timeout set for Sat Jun 13 18:53:44 2009
mount.nfs: text-based options: 'addr=<$IPADDR>' (placeholder for sanitization)
mount.nfs: mount(2): Operation not supported
mount.nfs: an incorrect mount option was specified

So DNS resolution works fine, no fstab entry, plain simple NFS mount. Fresh Fedora 11 installation, all post-release updates installed.

Workaround: using busybox.

[root@trinity ~]# busybox mount -t nfs discworld:/scratch /scratch
[root@trinity ~]#

Something is broken with mount.nfs I guess.

kernel-PAE-2.6.29.4-167.fc11.i686
nfs-utils-1.1.5-6.fc11.i586
Comment 1 Daniel Roesen 2009-06-13 14:24:48 EDT
Possibly duplicate of 505018 - very old NFS server... I'm going to test the pending nfs-utils update and report back.
Comment 2 Daniel Roesen 2009-06-13 14:30:04 EDT
Confirmation: The "-o proto=udp" workaround works fine.
Comment 3 Daniel Roesen 2009-06-13 14:34:26 EDT
nfs-utils-1.2.0-3.fc11.i586.rpm does NOT fix the issue.
Comment 4 Daniel Roesen 2009-06-13 14:35:58 EDT
I'm going to re-open Bug #505018 so we have all things in one place and close this one off as DUPLICATE.

*** This bug has been marked as a duplicate of bug 505018 ***

Note You need to log in before you can comment on or make changes to this bug.