Bug 505776 - Install of Fedora 11 hangs after selection of keyboard layout
Install of Fedora 11 hangs after selection of keyboard layout
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: DeviceKit-disks (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 14:39 EDT by kyle.m.douglass
Modified: 2013-03-05 22:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:58:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error report from the most recent installation attempt (LiveCD). (28.09 KB, text/plain)
2009-06-13 14:39 EDT, kyle.m.douglass
no flags Details
Text from console after the DVD installation fails. (437 bytes, text/plain)
2009-06-13 18:23 EDT, kyle.m.douglass
no flags Details

  None (edit)
Description kyle.m.douglass 2009-06-13 14:39:27 EDT
Created attachment 347757 [details]
Error report from the most recent installation attempt (LiveCD).

Description of problem:
The install of Fedora 11 hangs after selection of the keyboard layout using both the Live CD and the DVD graphical installer.

Using the Live CD, the Anaconda interface dumps me to the desktop. However, the circling blue swoosh beneath the mouse pointer (analogous to the Windows hour glass) appears and does not go away.

Using the DVD, I can make it to the same step in the process, but after selecting my desired keyboard layout and clicking next, the installer dumps me to a console screen and says that it is ok to reboot my system.

The last time I tried installing with the Live CD, I got an error report (which does not happen every time). I attached it with this report.


How reproducible:
Live CD: I boot with the Live CD as usual and double click on the "Install to Hard Drive" icon on the desktop. I click Next to get through the installer's welcome screen, choose my language, click Next, then choose my keyboard layout (I am going by memory on this sequence). I click Next on this screen and the problem described above happens.

DVD: After testing the DVD medium, I reached the installer welcome screen. I repeated the same steps as in the Live CD part mentioned above.

Actual results:
Live CD: I am dumped back to the desktop. Any programs that were originally running remain open.

DVD: I am dumped out of the graphical interface to a console. The last line of the console reports that it is ok to reboot my system.

Expected results:
I would expect to progress further through the installation.


Additional info: The error report I mentioned above is attached.

System specs:
E6600 Core 2 Duo 2.4 Gigahertz
Abit AB9 Mobo
2 X 1 GB OCZ PC6400 DDR2 800 MHZ Memory (Gold edition)
Seagate Barracuda 250 GB SATA2 HD (plugged into regular SATA port on mobo)
2x Western Digital 160 GB SATA2 HD (plugged into two JMicron SATA ports on mobo, JMicron chip is set to RAID 1)
ATI All-In-Wonder 2006 X1300 PCI Express

I suspect the motherboard may be causing the problem. In older versions of the Linux kernel, I seem to remember problems with my particular motherboard and the JMicron chipset.
Comment 1 kyle.m.douglass 2009-06-13 18:23:22 EDT
Created attachment 347782 [details]
Text from console after the DVD installation fails.
Comment 2 kyle.m.douglass 2009-06-14 16:57:28 EDT
Last night I tried booting the DVD with various permutations of "irqpoll," "pci=noacpi" and "noapci." This did not solve the problem.

I was eventually able to install onto the hard drive from the Live CD by unplugging the two 160 GB drives from the motherboard. I had also tried plugging all three drives into normal SATA ports but the same problem persisted. In the end, it seems that the OS can only recognize one HD plugged into the mobo at a time.
Comment 3 Chris Lumens 2009-06-29 14:15:37 EDT
The problem in the original bug report is being caused by the information we're getting back from udev, which is:

'DM_NAME': ['jmicron_JRAID', '\x01']
Comment 4 Harald Hoyer 2009-06-30 05:33:48 EDT
DM_NAME is provided by DeviceKit-disks, which is not component udev.
Comment 5 Bug Zapper 2010-04-27 10:52:41 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2010-06-28 08:58:22 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.