Bug 50578 - installer bails on redhat-release package
installer bails on redhat-release package
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-release (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 08:37 EDT by Mike Sklar
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 08:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Sklar 2001-08-01 08:37:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010712

Description of problem:
During a kickstart or manual installation of the July 29th 2001 rawhide
release the installer stops running while doing a package scan. The
complaint seems to be about the redhat-release package.

How reproducible:
Always

Steps to Reproduce:
1. grab rawhide july 29th release
2. try to install it
3.
	

Actual Results:  Traceback (innermost last):
  File "/usr/bin/anaconda", line 608, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 348, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 775, in run
    self.setup_window (runres)
  File "/usr/lib/anaconda/gui.py", line 755, in setup_window
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 502, in setScreen
    (step, args) = self.dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 239, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 139, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 102, in readPackages
    id.comps = method.readComps(id.hdList)
  File "/usr/lib/anaconda/image.py", line 17, in readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/usr/lib/anaconda/comps.py", line 771, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/lib/anaconda/comps.py", line 558, in readCompsFile
    self.expressions[packages[l]] = None
  File "/usr/lib/anaconda/comps.py", line 152, in __getitem__
    return self.packages[item]
KeyError: redhat-release

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 843f260>
item: redhat-release



Expected Results:  installation would ideally continued and completed

Additional info:
Comment 1 Bill Nottingham 2001-08-01 11:47:11 EDT
The rawhide installer is never guaranteed to work.

In any case, the particular problem (rawhide comps looking for redhat release
instead of rawhide-release) should be fixed in the next tree.

Note You need to log in before you can comment on or make changes to this bug.