Bug 505783 - Please rename OpenChange libmapi.so to avoid conflicts with Zarafa libmapi.so
Please rename OpenChange libmapi.so to avoid conflicts with Zarafa libmapi.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openchange (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 15:45 EDT by Robert Scheck
Modified: 2009-06-30 13:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 15:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-06-13 15:45:27 EDT
Description of problem:
We've the unfortunate situation, that OpenChange and Zarafa are providing a
libmapi.so library with different functionality, but same naming. According
to fedora-packaging, both libraries should get renamed to not conflict each
other.

Please read the following e-mails for your information:

 - https://www.redhat.com/archives/fedora-packaging/2009-June/msg00036.html
 - https://www.redhat.com/archives/fedora-packaging/2009-June/msg00037.html

In addition to my investigation to find information about libmapi.so, I got
told, that OpenChange libmapi.so only has 30% of the feature set of Zarafa
libmapi.so and currently OpenChange libmapi.so is not in productive usage at
hundreds of companies and organisations out there as Zarafa is already.

Thank you for your cooperation.

Version-Release number of selected component (if applicable):
openchange-0.8.2-2

Actual results:
Conflict between OpenChange libmapi.so and Zarafa libmapi.so.

Expected results:
No conflict due to renamed libmapi.so libraries.
Comment 1 Matthew Barnes 2009-06-21 08:56:30 EDT
Are you sure it's just libmapi.so that's in conflict?

OpenChange also installs:

  /usr/include/libmapi
  /usr/lib/libmapi.so
  /usr/lib/libmapiadmin.so
  /usr/lib/libmapiproxy.so
  /usr/lib/libmapiserver.so
  /usr/lib/libmapistore.so
  /usr/lib/pkgconfig/libmapi.pc
  /usr/lib/pkgconfig/libmapiadmin.pc
  /usr/lib/pkgconfig/libmapiproxy.pc
  /usr/lib/pkgconfig/libmapiserver.pc

Would it be sufficient to just move the libraries?

  /usr/include/openchange/libmapi
  /usr/lib/openchange/libmapi.so
  ...

Then just the pkg-config files would need modified/renamed.
Comment 2 Robert Scheck 2009-06-21 11:29:10 EDT
The only overlap is from my point of view only libmapi.so, not more:

  /usr/include/mapi4linux
  /usr/lib/libmapi.so -> libmapi.so.0.0.0
  /usr/lib/libmapi.so.0 -> libmapi.so.0.0.0
  /usr/lib/libmapi.so.0.0.0

There are some libraries such as libicalmapi.so* or libinetmapi.so*, but I
can't see there overlaps. The only pkg-config file is zarafa.pc which focuses
to Zarafa but not especially to Zarafa libmapi.
Comment 3 Matthew Barnes 2009-06-29 15:09:51 EDT
Fixed in openchange-0.8.2-3.fc12.

- Renamed /usr/lib/libmapi.so* to /usr/lib/libmapi-openchange.so*.
- Modified the pkg-config metadata to use the new library name.
- Rebuilt evolution-mapi against it.
Comment 4 Kevin Kofler 2009-06-30 12:51:11 EDT
I don't see why it wouldn't be Zarafa's job to rename the library, especially as it's internal to Zarafa and not used anywhere else.
Comment 5 Robert Scheck 2009-06-30 13:06:58 EDT
First, Matthew, thank you very much for your work! :)

As agreed with Toshio, both libraries will get renamed. And the library
from Zarafa is not only internal, it also can be used external, but as
of the moment, the package is a) not-yet in Fedora and b) no extensions
or similar stuff that could/would depend is packaged etc. because of a).
Comment 6 Matthew Barnes 2009-06-30 13:44:17 EDT
I'll speak with the OpenChange project and see if they'd be willing to install to a subdirectory -- e.g. $(libdir)/openchange -- so we don't have to permanently deviate from upstream.

Note You need to log in before you can comment on or make changes to this bug.