Bug 505789 - libvirt (creating virtual machine): Could not acquire pid file
libvirt (creating virtual machine): Could not acquire pid file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 16:38 EDT by Rene Pilz
Modified: 2009-06-16 16:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 16:04:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile of virt-manager (located at ~/.virt-manager) (100.62 KB, application/octet-stream)
2009-06-13 16:41 EDT, Rene Pilz
no flags Details

  None (edit)
Description Rene Pilz 2009-06-13 16:38:46 EDT
Description of problem:
When creating a new virtual machine at the end of the wizzard of virt-manager always rises an error. the log shows:
(/var/log/libvirt/qemu):
--cut--
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin HOME=/home/rene USER=root LOGNAME=root /usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name test -uuid f99e2e8f-cbcd-36cf-ad12-60a7fc4ac348 -monitor pty -pidfile /var/run/libvirt/qemu//test.pid -no-reboot -no-acpi -boot d -drive file=/var/lib/libvirt/images/Test.img,if=ide,index=0 -drive file=/home/rene/virtBootImages/NortonGhost2003.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:30:3f:b2,vlan=0 -net tap,fd=23,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 
Could not acquire pid file
--cut--

Specially this "Could not acquire pid file" looks strange to me, because the folder for the pid-file /var/run/libvirt/qemu/ exists?

When copying the command to the Command-Line (LC_ACLL=C PATH=....) anything looks good and the virtual machine is accessable. But still not within virt-manager!

The same behavier shows when trying to start a already existing virtual machine (one created at F10, before the upgrade to F11)

Version-Release number of selected component (if applicable):
libvirt.x86_64                             0.6.2-11.fc11          installed     
libvirt-python.x86_64                      0.6.2-11.fc11          installed     
python-virtinst.noarch                     0.400.3-8.fc11         installed     
virt-manager.x86_64                        0.7.0-5.fc11           installed
Comment 1 Rene Pilz 2009-06-13 16:41:26 EDT
Created attachment 347770 [details]
Logfile of virt-manager (located at ~/.virt-manager)
Comment 2 Rene Pilz 2009-06-16 16:04:22 EDT
Solved with the lastest updates for F11

Note You need to log in before you can comment on or make changes to this bug.