Bug 505795 - yum-changelog crashes due to invalie updateinfo.xml
yum-changelog crashes due to invalie updateinfo.xml
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
i686 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 18:27 EDT by dex
Modified: 2014-01-21 18:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 17:50:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum output with debug 9 (6.27 KB, text/plain)
2009-06-13 18:27 EDT, dex
no flags Details
yum output with debug 9 success (6.00 KB, text/plain)
2009-06-13 18:31 EDT, dex
no flags Details
yum output with debug (20.80 KB, text/plain)
2009-06-13 21:38 EDT, dex
no flags Details

  None (edit)
Description dex 2009-06-13 18:27:07 EDT
Created attachment 347783 [details]
yum output with debug 9

Description of problem:
yum-changelog crashes yum

Version-Release number of selected component (if applicable):
yum-utils-1.1.22-1.fc11.noarch

How reproducible:
intermittent

Steps to Reproduce:
1. sed -i 's/^always=false/always=true/' /etc/yum/pluginconf.d/changelog.conf
2. yum -d 9 update man pango gtk2 libv4l rsync
3.
  
Actual results:
see attached

Expected results:
I read the changelog.

Additional info:
using --disableplugin=changelog results in success.

Also this is a LiveCD install from ~2wks ago so some of the updates are comming from the fedora.repo these seem to succeed where {updates/testing}.repo seem to fail. 
I've attached a good run from the fedora.repo also.
Comment 1 dex 2009-06-13 18:31:10 EDT
Created attachment 347784 [details]
yum output with debug 9 success
Comment 2 dex 2009-06-13 21:34:46 EDT
OK it looks like the repos have nothing to do with it and its at the package level because this works 100%:
yum -d 9 update man pango gtk2 libv4l cups
see attached log.
The rsync package is causing yum-changelog to fail.
Comment 3 dex 2009-06-13 21:38:29 EDT
Created attachment 347791 [details]
yum output with debug
Comment 4 James Antill 2009-06-14 20:27:38 EDT
 This is the update info problem in Fedora (updateinfo.xml is invalid, containing entries without id's). We've changed upstream to work around it, feel free to apply:

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=4ec72c0bf27474c61d4295576b59fc95030e547c

...manually, or wait for Fedora to fix their updateinfo (or for a new yum to appear in Fed-11 updates-testing, whichever is sooner).

Note You need to log in before you can comment on or make changes to this bug.