Bug 505808 - New Install of Fedora 11
New Install of Fedora 11
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-pyblock (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
anaconda_trace_hash:2872baf89830042e9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 23:02 EDT by Jeff
Modified: 2010-01-05 04:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 04:41:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (30.69 KB, text/plain)
2009-06-13 23:02 EDT, Jeff
no flags Details

  None (edit)
Description Jeff 2009-06-13 23:02:33 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59-1.fc11 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/block/__init__.py", line 35, in dm_log
    raise Exception, message
  File "/usr/lib/python2.6/site-packages/block/device.py", line 719, in get_map
    self._RaidSet__map = _dm.map(name=self.name, table=self.rs.dmTable)
  File "/usr/lib/python2.6/site-packages/block/device.py", line 822, in activate
    self.map.dev.mknod(self.prefix+self.name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1407, in handleUdevDMRaidMemberFormat
    rs.activate(mknod=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1543, in handleUdevDeviceFormat
    self.handleUdevDMRaidMemberFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1201, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1691, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 302, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 73, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
Exception: device-mapper: reload ioctl failed: Invalid argument
Comment 1 Jeff 2009-06-13 23:02:38 EDT
Created attachment 347795 [details]
Attached traceback automatically from anaconda.
Comment 2 Jeff 2009-06-13 23:16:23 EDT
I was doing a fresh install of Fedora 11 Gnome addition.  The install GUI starts with keyboard selection and then proceeds to search for an install destination.  It is there that the install fails and produces the submitted report.  I can install a fresh F10 with no problems.  This problem occurs both with the F11-Gnome spin and the KDE spin (KDE adds a Selinux block)

The Gnome GUI also alerted me that one of my hardrives is failing however, I was attempting to install it on my external drive.  Nevertheless, hardware might be an issue here, but I am not sure, as the F10 will install without issue to the external drive.

I will change the failing drive (a Raid 5 member) and see if that is a problem.  The Gnome-Livecd ISO that I have is fine, as I installed it in Virtual Box on through my Window XP partion.
 
That's it for background info.  Would be curious as to what you can discover by the above report.
Comment 3 Jeff 2009-06-16 23:30:46 EDT
I just attempted to install the F11 64 bit live cd.  I get the same issue.  Gnome still detects an issue with a hard drive in my raid array.  I'm thinking that may be the issue.  I was able to install F11 in Virtual Box via Windows XP.  I'll be swithing drives in the next few weeks.  We'll see if that is the issue.  Funny, XP doesn't have a problem with it and neither did F10.  Only F11 had issues.
Comment 4 Miked 2009-08-29 18:18:36 EDT
I have the same problem. I cannot install Fedora 11 because of this.  I am installing from a real DVD (64 bit system) which passes the scan testing.

I cannot upload the exception report because when clicking on SAVE, the dialogue box comes up along with a message box  "Finding storage devices...".  This just hangs. I have to power down the system to regain control.

My AMD system is running Fedora 10 perfectly well.  The system disks are a pair of 1TB Sata drives with software RAID (mirrors) and LVM.  There are also four Sata 500GB drives configured as software RAID 5 and LVM used as data disks.

It looks like I am stuck on Fedora 10 until this is fixed or there is a workaround.
Comment 5 Jeff 2009-08-30 13:10:07 EDT
I did fix one of the problems.  This was originally a Windows system running Intel Raid 5.  I rebooted the computer and released the Raid Members so all drives were running on their own.  Then I booted the F1164bit and installed using Fedora's Raid.  Everything installed fine.  I still have a lot to learn regarding how Linux handles Raid.  As far as my issue is concerned, it was solve by using Raid in Fedora.
Comment 6 Miked 2009-08-30 15:50:54 EDT
I am preparing to do something similar, I am doing a dump of all filesystems (this is in addition to my BackupPc regular backups). I will then trash the data drives returning them to raw.   I suspect that the Fedora initial install cannot handle complex software RAID and LVM.  I expect that the partitioning tools later on in the process will do so.   It may be beneficial to leave a few GBytes of raw disk storage available to enable the installer to get past this stage in the future.

My RAID and LVM are all Fedora (9 or 10) based.  I had hoped that the initiation of the install would have recognised these so I could have done an update rather than full install as I would not then have had to reconfigure all the services.

Thanks for confirming my suspicions, I will report back after I have completed the install process.
Comment 7 Bug Zapper 2009-11-16 05:11:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Hans de Goede 2010-01-05 04:41:59 EST
Jeff,

You had an Intel BIOS RAID 5 set, but RAID 5 is not supported by dmraid, see bug
533703. Note that for Fedora-12, if you use the install DVD (not he livecd), we have moved over to using mdraid for Intel BIOS RAID which does support RAID 5.

I'm closing this with a resolution of current release, as the issue was the use of Intel BIOS RAID 5, which no longer is an issue in Fedora 12.

Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.