Bug 505816 - Failure to create encrypted Ext3 partitions
Failure to create encrypted Ext3 partitions
Status: CLOSED DUPLICATE of bug 494150
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 00:36 EDT by Debarshi Ray
Modified: 2009-07-20 09:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 11:45:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Debarshi Ray 2009-06-14 00:36:41 EDT
Description of problem:
Trying to create an encrypted Ext3 partition for /home crashed Anaconda on an Intel Macbook.

The traceback complains about a missing 'mapName' in Ext3FS object.


Version-Release number of selected component (if applicable):

Version shipped with Fedora 11 x86_64 DVD. Similar problem in the Fedora 11 PR x86_64 DVD.
Comment 1 Chris Lumens 2009-06-29 11:45:10 EDT

*** This bug has been marked as a duplicate of bug 494150 ***
Comment 2 Martin Sivák 2009-07-17 08:39:46 EDT
I did a clean instalation of F11, but didn't see the error.

I used

1) Use entire drive
2) I modified the /boot to be only 100Mb big
3) I created encrypted ext3 /home with 100MB of space

I ignored the warning about the size (It just a test right..)

F11 base packages installed successfully. Is there anything else I should know about the environment? Old instalations, multiple drives.. anything special at all?
Comment 3 Debarshi Ray 2009-07-17 08:53:34 EDT
This is a Apple Macbook, which had Fedora 9 x68_64 on it. A fresh new installation of Fedora 11 x86_64 was being attempted with "create custom layout" (to dual boot with MacOS X) and the following layout:

(parted) print
Model: ATA Hitachi HTS54168 (scsi)
Disk /dev/sda: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name                  Flags
 1      20.5kB  210MB   210MB   fat32        EFI System Partition  boot 
 2      210MB   21.6GB  21.3GB  hfs+         Apple_HFS_Untitled_1       
 3      21.6GB  21.7GB  101MB   ext2                                    
 4      21.7GB  51.7GB  30.1GB                                          
 5      51.7GB  68.2GB  16.5GB  ext3                                    
 6      68.2GB  79.0GB  10.7GB  ext3                                    
 7      79.0GB  80.0GB  1074MB  linux-swap                              

(parted)     

The partition with the encrypted filesystem is /dev/sda4.
Comment 4 Martin Sivák 2009-07-20 09:12:36 EDT
Can you attach the /tmp/anaconda.log and /tmp/program.log files from the broken instalation? Or if you are able to reproduce the crash, use anaconda's save-to-bugzilla or scp feature to give us more information.

And could describe the exact steps you did to reproduce the crash please?

It is hard to debug a failure without information.

Note You need to log in before you can comment on or make changes to this bug.