Bug 505817 - Can not boot Fedora 11 on Intel Macbooks or iMacs
Can not boot Fedora 11 on Intel Macbooks or iMacs
Status: CLOSED DUPLICATE of bug 503149
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
https://www.redhat.com/archives/fedor...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 00:44 EDT by Debarshi Ray
Modified: 2010-03-02 14:06 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 11:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Debarshi Ray 2009-06-14 00:44:30 EDT
Description of problem:

Trying to boot the system after installing Fedora 11 on it fails with the following message if the Fedora 11 x86_64 DVD was used:
"No bootable device -- insert boot disk and press any key.

This particular machine is dual booted with MacOSX using rEFIt.


Version-Release number of selected component (if applicable):

Version shipped with the Fedora 11 x86_64 DVD. Similar problem with the Fedora 11 PR x86_64 DVD too.


Additional info:
https://www.redhat.com/archives/fedora-test-list/2009-June/msg00471.html
Comment 1 Eelco Hoekema 2009-06-14 06:35:25 EDT
How i fixed it:
At the rEFIt boot screen, i chose the shell where i ran gptsync. It said syncing was required, and so i did. After syncing, exit the shell, and reboot. Now i could choose fedora in the rEFIt menu. (The first time, it seemed to hang after choosing linux, but after a hard reboot, fedora booted.)

If you have a new model MacBook (5.1), you should beware though that Fedora is not ready for this model yet. Especially trackpad and sound are a problem, and you'll need closed source drivers for your wireless, and you'll probably want them for your graphics driver as well.
Comment 2 Jurgen Kramer 2009-06-14 06:40:44 EDT
I've just installed F11 (x86_64) on my iMac and experienced the same problem. I fixed it with starting the refit tools. Refit suggested to resync the mbr as it was not updated. After updating it all works as it should.

I did not have this problem with F10. It seems anaconda (?) forgot to sync the mbr partition after partitioning.
Comment 3 Debarshi Ray 2009-06-14 10:49:13 EDT
Thank you very much. 'gptsync' fixed the problem for me, and it did not even seem to hang the first time.

(It is not the latest 5.1 Macbook that I am using. In fact I have been using Fedora on it since Fedora 9.)
Comment 4 Aivaras 2009-06-14 11:32:27 EDT
I fixed installing grub in boot directory -> setup (hd0,0), not in mbr setup(hd0)
Comment 5 Andy Lindeberg 2009-06-15 15:10:45 EDT
rEFIt is not included in Fedora. If you're using rEFIt, a solution/workaround is noted in comment #1.
Comment 6 Eelco Hoekema 2009-06-15 15:21:23 EDT
It seems Anaconda messes up the MBR. Installing F10 went fine, installing F11 leads to boot problems. So how is this not a bug?
Comment 7 Bill McGonigle 2009-06-15 22:52:14 EDT
follow bug 444490 for the anaconda problem
Comment 8 Debarshi Ray 2009-06-16 00:33:44 EDT
(In reply to comment #5)
> rEFIt is not included in Fedora. If you're using rEFIt, a solution/workaround
> is noted in comment #1.

Given that I have been using this setup of rEFIt + MacOS + Fedora since the Fedora 9 days, do you mean to say that from Fedora 11 onwards rEFIt is not meant to work? Otherwise this is a regression.
Comment 9 Andy Lindeberg 2009-06-16 11:12:32 EDT
(In reply to comment #8)
> Given that I have been using this setup of rEFIt + MacOS + Fedora since the
> Fedora 9 days, do you mean to say that from Fedora 11 onwards rEFIt is not
> meant to work? Otherwise this is a regression.  

This working in previous versions of Fedora is purely coincidence - it has never been supported.
Comment 10 Jurgen Kramer 2009-06-16 12:23:24 EDT
Why is this bug closed? Anaconda should have updated the mbr as it did in F10! So In my opinion yes, this is a regression.

Normally anaconda is (should be) aware of gpt partitions.
Comment 11 Aivaras 2009-06-16 12:30:47 EDT
And in my case is just Fedora and nothing else. After upgrade from Fedora 10, i had no boot, so I fixed installing grub in boot directory -> setup (hd0,0), not in mbr setup(hd0)
Comment 12 Eelco Hoekema 2009-06-16 13:35:58 EDT
Stating that the working was purely coincidence implies that Fedora basically does not support MacBooks or MacBook Pros.
Comment 13 Jeremy Katz 2009-06-16 14:18:12 EDT
Andy -- this used to work intentionally.  We lost some bits in the storage rewrite and there's another bug where I detailed what we're missing for Chris.  Just a matter of getting the right things plugged back in

All the testing on the Intel Macs was apparently done using EFI instead of through the legacy/BIOS boot compat
Comment 14 Bill McGonigle 2009-06-16 14:40:24 EDT
As I understand it, rEFIt is just a graphical chooser - it doesn't do anything that the EFI shell wouldn't.  Apple's implementation looks to be EFI 1.1 with BIOS emulation support.

Fedora doesn't usually have an HCL, it supports certain technologies or not.  One would expect something that breaks EFI/rEFIt on Macs to break other EFI/BIOS implementations as well - Apple is just the most prolific manufacturer of EFI machines.
Comment 15 Jeremy Katz 2009-06-16 14:52:15 EDT
(In reply to comment #14)
> Fedora doesn't usually have an HCL, it supports certain technologies or not. 
> One would expect something that breaks EFI/rEFIt on Macs to break other
> EFI/BIOS implementations as well - Apple is just the most prolific manufacturer
> of EFI machines.  

Most other EFI machines that also have a legacy BIOS end up using standard MBR/MSDOS partitioning rather than GPT.  

The Apple boxes really do have a fair number of quirks unfortunately.
Comment 16 Andy Lindeberg 2009-06-16 14:56:23 EDT
Then I have been misled by dcantrell! You can have it.
Comment 17 Jeremy Katz 2009-07-08 11:12:50 EDT

*** This bug has been marked as a duplicate of bug 503149 ***

Note You need to log in before you can comment on or make changes to this bug.