Bug 505825 - system-config-users fails to create home dir if an intermediate directory is missing
system-config-users fails to create home dir if an intermediate directory is ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 03:10 EDT by Andrei Gaponenko
Modified: 2016-08-11 07:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 07:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Gaponenko 2009-06-14 03:10:05 EDT
Hi,

The system-config-users utility fails to create home directory for a
new user if the parent directory of the requested home does not exist.
That is, it acts similar to "mkdir <home>", while it would be more
sensible to act like "mkdir -p <home>".

Version-Release number of selected component (if applicable):

system-config-users-1.2.86-1.fc11.noarch

How reproducible: always

Steps to Reproduce:

1.  start system-config-users

2.  click "add user"

3.  enter a new username (e.g. "test5") and password.  Make
    sure the "create home directory" box is checked, and change
    /home/test5 to /home/subdir/test5. Click "OK".
    
Actual results: user "test5" is created but its home directory does
not exist.

Expected results: User's home directory should be created.

Thank you,
Andrei
Comment 1 Nils Philippsen 2016-08-11 07:54:03 EDT
Thanks for taking the time to submit this request for enhancement.
Unfortunately, I haven't gotten around to implement this feature, sorry for
that.

Because I don't actively develop system-config-users anymore, I won't likely
find the time to work on this ticket, so I'll close it now.

Note You need to log in before you can comment on or make changes to this bug.