Bug 505829 - intel kms: display only goes till 800x600
intel kms: display only goes till 800x600
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 03:44 EDT by Amit Shah
Modified: 2010-04-14 03:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-14 03:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (42.62 KB, text/plain)
2009-06-14 03:44 EDT, Amit Shah
no flags Details
Xorg.0.log (45.58 KB, text/plain)
2009-06-14 03:46 EDT, Amit Shah
no flags Details
dmesg-nokms (41.86 KB, text/plain)
2009-06-14 08:27 EDT, Amit Shah
no flags Details
Xorg.0.log-nokms (58.37 KB, text/plain)
2009-06-14 08:28 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2009-06-14 03:44:58 EDT
Created attachment 347804 [details]
dmesg

Description of problem:
After installing F11 from the DVD, the display properties show only the 800x600 and 640x480 options.

Will attach dmesg and Xorg.0.log. Will also test with nomodeset and report.
Comment 1 Amit Shah 2009-06-14 03:46:01 EDT
Created attachment 347805 [details]
Xorg.0.log

I don't have a /etc/X11/xorg.conf
Comment 2 Amit Shah 2009-06-14 08:27:26 EDT
Created attachment 347816 [details]
dmesg-nokms

With nomodeset=1 the display only goes to 1024x768. Still not what the monitor is capable of doing
Comment 3 Amit Shah 2009-06-14 08:28:50 EDT
Created attachment 347817 [details]
Xorg.0.log-nokms
Comment 4 Adam Jackson 2009-06-29 11:59:24 EDT
What display is this?  It looks like we're not getting EDID from it at all.
Comment 5 Amit Shah 2009-06-29 12:28:52 EDT
http://www.amazon.com/Samsung-SyncMaster-740N-17-inch-Monitor/dp/B000BT2PZS

I attached another monitor, an old 15" CRT (also samsung). That too could only do 800x600.

(also: all the F11 installs I've tried are 64-bit. I've not yet tried a 32-bit install; though it doesn't sound like a problem with the bitness.)
Comment 6 Amit Shah 2009-07-16 02:05:36 EDT
Is there any hope for this to work on this monitor at all?
Comment 7 Amit Shah 2009-07-16 03:08:23 EDT
In other words, can the EDID requirement be worked around and a custom resolution be specified? (I tried making a minimal xorg.conf but that didn't work.)
Comment 8 Amit Shah 2009-08-13 07:44:17 EDT
Actually I could get 1280x1024 by using an xorg.conf and getting the modeline from 'cvt' output. Works with kms enabled as well as disabled.

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
	Option	"PreferredMode" "1280x1024_60.00"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "CacheLines"         	# <i>
        #Option     "Dac6Bit"            	# [<bool>]
        #Option     "DRI"                	# [<bool>]
        #Option     "NoDDC"              	# [<bool>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "XvMCSurfaces"       	# <i>
        #Option     "PageFlip"           	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "82G965 Integrated Graphics Controller"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	DefaultColorDepth 24

	SubSection "Display"
		Depth     24
		Modes     "1280x1024"
	EndSubSection
EndSection
Comment 10 Matěj Cepl 2009-11-05 13:31:48 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 11 Amit Shah 2010-04-14 03:43:16 EDT
This is a hardware bug: monitor doesn't expose EDID information.

Note You need to log in before you can comment on or make changes to this bug.