This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505871 - anaconda exception: "lvdeactivate failed for..."
anaconda exception: "lvdeactivate failed for..."
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-06-14 09:03 EDT by juergen leising
Modified: 2013-01-10 00:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 13:16:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juergen leising 2009-06-14 09:03:39 EDT
Description of problem:

Trying to install fedora 11 onto already existing lvm2 partitions
fails no matter what I do.  I start from "Create custom layout" and
then I can choose whether or not to change the size of the partitions
or whether or not to format them.

In one out of several tries, however, I got an anaconda exception.
As in previous releases the automatic save did not work, again.  But I could
save the anacdump.txt manually in a vty:


anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 410, in lvdeactivate
    raise LVMError("lvdeactivate failed for %s" % lv_name)
  File "/usr/lib/anaconda/storage/devices.py", line 2116, in teardown
    lvm.lvdeactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/__init__.py", line 1079, in findExistingRootDevices
    device.teardown(recursive=True)
  File "/usr/lib/anaconda/upgrade.py", line 162, in findExistingRoots
    rootparts = findExistingRootDevices(anaconda, upgradeany=upgradeany)
  File "/usr/lib/anaconda/upgrade.py", line 136, in findRootParts
    anaconda.id.rootParts = findExistingRoots(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: lvdeactivate failed for hda_fc10_rootfs



Wild guess:

anaconda/parted seem to have problems with LVM2 when the
underlying physical devices are SATA disks.  Because this
was not the case when I installed fc10 on the very same computer.

From fc10:

lspci (partial)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)



Version-Release number of selected component (if applicable):

I tried to install from the official fedora 11 release (in form of CDs:
disk 1).

How reproducible:

The exception does NOT show up (at least I cannot see it) when
no changes of any partition sizes and no formatting is to be performed.


Steps to Reproduce:
1. Install fc11 on a computer with already existing LVM2 volumes.
2. Choose "Create custom layout"
3. Try and have the volumes be formatted.
  

Actual results:

The exception occurs and "exit the installer". 

Can't you just ignore such errors? I could do the partitioning
and formatting outside of the buggy installer.

But with "Exit the installer" it is pretty much a show-stopper
for me.

Expected results:

Installation on already existing lvm volumes without exit conditions,
regardless of whether there is anything to do with the partitions/volumes.


Additional info:

Similar, but not identical bug reports:

https://bugzilla.redhat.com/show_bug.cgi?id=504987

https://bugzilla.redhat.com/show_bug.cgi?id=492670



Bye, bye

Juergen
Comment 1 Chris Lumens 2010-03-02 14:28:59 EST
If you can still reproduce this problem with F12 or F13 alpha, can you please attach /tmp/storage.log and /tmp/program.log to this bug report?  Since F11 there's been a major storage rewrite that means it's difficult to tell whether older bugs are really still valid or not.  Thanks.
Comment 2 juergen leising 2010-03-03 14:42:47 EST
When I installed F12, the problem did NOT occur. From this I would conclude,
that the issue has been fixed.  However, I have not installed F13 alpha, yet.
I am going to install F13 alpha onto a fresh disk with LVM on it in the next 
one or two weeks.  Not until then I can tell you whether or not I can consider 
this as resolved.

Bye, bye

Juergen
Comment 3 Chris Lumens 2010-04-05 17:35:28 EDT
I'm going to set this to MODIFIED on the basis of comment #2 stating it works in F12.  If you see this problem in F13, feel free to put it back into ASSIGNED with the requested information and we'll take another look.  Thanks for the testing.
Comment 4 juergen leising 2010-04-13 13:11:36 EDT
I have just installed F13-alpha on freshly created logical volumes. And it works.
So the bug has been fixed, as it seems.

Juergen
Comment 5 Chris Lumens 2010-04-13 13:16:41 EDT
Great, thank you for retesting.

Note You need to log in before you can comment on or make changes to this bug.