Bug 50589 - mount doesn't honor "mode" option
mount doesn't honor "mode" option
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 09:31 EDT by edgester
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 04:37:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description edgester 2001-08-01 09:31:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Redhat 7.0/7.1  in mount versions: 2.10r-5 and 2.11b-3 repectively, mount
doesn't honor the mode option. however, it does honor the umask option.
either the mode option needs to be fixed, or removed from the command and
man pages.
Tested in Redhat 7.0/7.1 with the mount versions specified.

How reproducible:
Always

Steps to Reproduce:
1.mount /dev/fd0 -o mode=111 /mnt/floppy
2.
3.
	

Actual Results:  tried with vfat disks only. ls -l /mnt/floppy shows all
files have mode 755  no matter what mode is specified.

Additional info:

workaround, use the umask option for mount.
this problem is also present in autofs. but i suspect that fixing mount
would fix autofs.
Comment 1 Habig, Alec 2001-12-02 13:45:37 EST
Still here with RH 7.2's mount-2.11g-5 package.
Comment 2 Christopher Holmes 2002-03-01 16:57:47 EST
*** Bug 60548 has been marked as a duplicate of this bug. ***
Comment 3 Elliot Lee 2002-04-15 11:33:06 EDT
The current man page mentions nothing about the mode= option for fat/vfat
filesystems. Seems fixed.

Note You need to log in before you can comment on or make changes to this bug.