Bug 50592 - cpqfc is getting loaded and its drives found as first drives during install (boot order issue)
cpqfc is getting loaded and its drives found as first drives during install (...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 09:38 EDT by Bryan Leopard
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 15:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-08-01 09:38:58 EDT
cpqfc drives are being found as first scsi devices(/dev/sda and /dev/sdb).
This can mislead the user to select cpqfc drive as a boot device while 
fibre channel can not be a boot device.
Fibre channel drives should be last scsi devices.

System: ML530 (2P)
controllers: Embedded SCSI, adaptec scsi controller(slot 6), Compaq fibre 
channel controller(slot 7). 
OS: RH Roswell Beta3

Steps to reproduce:
1. Start installation using CD
2. Choose GUI installation 
3. DiskDruid shows 2 cpqfc logical volumes as /dev/sda and /dev/sdb.
Comment 1 Matt Wilson 2001-08-01 11:23:56 EDT
We need to work with Comapq to discover an interface to find out the order that
the BIOS will be accessing drives to boot from.
Comment 2 Glen Foster 2001-08-23 17:51:38 EDT
This defect is considered MUST-FIX for Fairfax.
Comment 3 charles.white 2001-09-10 10:17:25 EDT
What about having the cpqfc driver on the CD, but NOT loading it during 
install?  Afterwords the driver can be loaded last, be putting it last in the 
modules.conf file. 

The problem is that this is NOT a bootable controller and lilo requires you to 
use sda as your bootable controller. 
Comment 4 Matt Wilson 2001-09-12 11:53:32 EDT
lilo does not require you to use sda as your bootable controller.

for lilo:

disk=/dev/sdi
	bios=0x80

(make sdi your boot drive)

for grub:

edit /boot/grub/device.map

change:

(hd0)     /dev/sda

to
(hd0)     /dev/sdi

Comment 5 Jeremy Katz 2002-01-21 20:09:55 EST
Boot order manually changable for Hampton

Note You need to log in before you can comment on or make changes to this bug.